when i ./configure in the catalog of gtk ,there will be mistake :
checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.13.5 atk >= 1.9.0 pango >= 1.17.3 cairo >= 1.2.0) were not met:
Requested 'glib-2.0 >= 2.13.5' but version of GLib is 2.12.3
Requested 'pango >= 1.17.3' but version of Pango is 1.14.9
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
The version of glib in my computer is 2.6.1
[root@localhost ~]# rpm -q glib
I installed glib in /opt/glib2.6 previously , so append the path of glib in PKG_CONFIG_PATH that is :
[root@localhost ~]# echo $PKG_CONFIG_PATH
why there show the version of glib is 2.12.3,where is the problem?
so i cant install Pango too ,the same problem is also occurred when execute ./configure in the catalog of pango :
checking for GLIB... no
*** Glib 2.14.0 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/