LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-23-2012, 05:54 AM   #1
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 719

Rep: Reputation: 103Reputation: 103
gtk-config in path..... Build Failure


I am trying to install a package and I am getting the error below. I tried removing the package in question and letting packer re install but no dice. I have read the man page for pkg-config but I am not clear as to next steps.

Any direction would be appreciated.



Code:
Command --> 

packer -S lib32-cnijfilter-mp560

-----> Error

checking for GTK+ - version >= 2.0.0... 
*** 'pkg-config --modversion gtk+-2.0' returned 2.24.11, but GTK+ (2.24.10)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GTK+. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: Cannot find GTK: Is gtk-config in path?
==> ERROR: A failure occurred in build().
    Aborting...
The build failed.
Running Arch-Linux 64 Bit.

Last edited by jv2112; 07-23-2012 at 06:09 AM.
 
Old 07-23-2012, 08:25 AM   #2
rmugunthan
Member
 
Registered: Jan 2009
Location: Coimbatore, India
Distribution: rhel
Posts: 49

Rep: Reputation: 3
Post the output of below commands

echo $PKG_CONFIG_PATH
echo $LD_LIBRARY_PATH
echo $PATH

And also let me know, two different version of gtk installed or not? If installed where those installed binary files are present.
 
Old 07-24-2012, 05:36 AM   #3
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 719

Original Poster
Rep: Reputation: 103Reputation: 103
Thank You very much for the response.

I tried as normal user and Root and both outputs are the same for the first two,
Code:
I get zero output for the first two--->

joe@Tux-Box  in Desktop$ echo $PKG_CONFIG_PATH

joe@Tux-Box  in Desktop$ echo $LD_LIBRARY_PATH

joe@Tux-Box  in Desktop$ echo $PATH
/usr/local/sbin:/usr/lib:/usr/lib64:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin:/home/joe/Scripts:/opt/java/jre

Installed GTK ( I only see the one)

Code:
packer -Ss gtk | grep installed | sort -nk 2 -->

community/ruby-gtk2 1.1.3-2 [installed]
extra/clutter-gtk 1.2.0-1 [installed]
extra/gtk 1.2.10-11 [installed]
multilib/lib32-gtk 1.2.10-12 [installed]
extra/gtkspell 2.0.16-2 [installed]
extra/gtk-engines 2.21.0-1 [installed]
extra/gtk2 2.24.11-2 [installed]
extra/gtkmm 2.24.2-2 [installed]
extra/gtk-update-icon-cache 2.24.11-2 [installed]
extra/pygtk 2.24.0-3 [installed]
multilib/lib32-gtk2 2.24.10-1 [installed]
extra/avidemux-gtk 2.5.6-3 [installed]
extra/transmission-gtk 2.60-1 [installed]
extra/gtk2-xfce-engine 3.0.0-1 (xfce4) [installed]
extra/gtk3 3.4.4-1 [installed]
extra/gtksourceview3 3.4.2-1 [installed]

Code:
pacman -Qi gtk2 -->

Name           : gtk2
Version        : 2.24.11-2
URL            : http://www.gtk.org/
Licenses       : LGPL
Groups         : None
Provides       : None
Depends On     : atk  pango  libxcursor  libxinerama  libxrandr  libxi  libxcomposite  libxdamage  shared-mime-info  cairo  libcups  gtk-update-icon-cache
Optional Deps  : None
Required By    : avidemux-gtk  dia  exo  firefox  flashplugin  gegl  goffice  gtk-engines  gtk2-xfce-engine  gtkmm  gtkspell  guake-git  handbrake  icedtea-web-java7  lib32-gtk2
                 libdesktop-agnostic  libgksu  libglade  libreoffice-gnome  libunique  libwebkit  libwnck  libxfce4ui  medit  mx  obconf  openbox-menu  opencv  parcellite  ruby-gtk2
                 thunar  thunderbird  vte  xarchiver  xchat  xcowsay
Conflicts With : None
Replaces       : gtk2-docs
Installed Size : 57268.00 KiB
Packager       : Ionut Biru <ibiru@archlinux.org>
Architecture   : x86_64
Build Date     : Sun 22 Jul 2012 04:55:45 AM EDT
Install Date   : Mon 23 Jul 2012 05:38:27 AM EDT
Install Reason : Installed as a dependency for another package
Install Script : Yes
Description    : GTK+ is a multi-platform toolkit (v2)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GTK source install doesn't give gtk-config Feebles Linux - Software 4 06-15-2005 01:51 PM
cant find gtk-config file or gtk-devel to install happychappy Linux - Software 2 02-16-2005 01:46 AM
gtk-config was not found in your $PATH eerf Debian 1 01-19-2005 04:47 AM
[Debian]gtk-config was not found in your $PATH eerf Linux - Security 1 01-18-2005 10:26 PM
GTK install/config, path problems greennick Linux - Software 3 09-18-2002 04:17 AM


All times are GMT -5. The time now is 03:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration