LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   grub time out - selections (http://www.linuxquestions.org/questions/linux-newbie-8/grub-time-out-selections-93340/)

CloudBuilder 09-16-2003 06:50 AM

grub time out - selections
 
I have a dual system RH9 and ME on an ASSUS 3500 Laptop.

I Installed GRUB. Works fine except one thing, If I do nothing at start up, Grub does not wait for my input !

If I touch space I get the selection display.

I have set the time-out to 100, and so I have a very short time to respond. Any Suggestions?

=============

After updating RH I found 2 different RH selection points on my startup screen. Do I get a new selection point by each change?

Should I edit them as comment, or can I throw them away without problems?

CB

rberry88 09-16-2003 07:20 AM

Are you asking if you can make the timeout longer in Grub?? If so, then just edit your Grub file. I believe it is in Grub -> menu.lst.

If you're asking something totally different then someone else will need to jump in.

rberry88

CloudBuilder 09-16-2003 03:05 PM

Quote:

Originally posted by rberry88
Are you asking if you can make the timeout longer in Grub?? If so, then just edit your Grub file. I believe it is in Grub -> menu.lst.

If you're asking something totally different then someone else will need to jump in.

rberry88

As I told I have edited the file for GRUB and put the delay to 100
This gives a delay from anout 3 to 5 secconds.

If there is no other way I'll make it 500.

The seccond question is that after an update(of RH) I find a new entry in Grub.

I started with 2 one for windows (DOS) and one for RH. Now I have 2 for RH and 1 for dos.

Do I have 4 next time I update ?

CB

rberry88 09-16-2003 03:11 PM

I think the new entry is for the new kernel and the other for the old kernel, I could be wrong though.

My time out in Grub is 7 seconds, default setting.

rberry88

aqoliveira 09-16-2003 03:21 PM

Hi

Login as root and edit the /etc/grub.conf file then type in a line that says timeout 30 this will boot your default selection after 30 seconds.

The answer to the second quetion is that when u updated from RHN it updated your kernel the next time u boot up u will see that there are two versions of the kernel the old and the new one. e.g Red Hat Linux (2.4.20-20.9smp) and the older entry like this Red Hat Linux (2.4.20-18.9) notice the numbers are diffrent. Usually the older is keot just in case there was problems with the new one.

The next time u update there might not have a kernel update therefor the entries stay the same but if there was then u will have another entry apear.

Chow

CloudBuilder 09-16-2003 04:04 PM

Quote:

Originally posted by aqoliveira
Hi

Login as root and edit the /etc/grub.conf file then type in a line that says timeout 30 this will boot your default selection after 30 seconds.

Chow

I have already a time out from 100 in this file, I 'll make it 500 and probably the system is waiting for me.

(I tried out some settings 200 will do. But I don't know why and I don't like that.)

This is an ASSUS Laptop 3500D .

It is starting with some kind of Assus logo and while this is on the screen I have to touch the space bar. Only then the systems counts its seconds in a normal way. If I don't press space it will wait about 3 to 5 seconds with timeout 100.

Thanks for the explanation about the versions.

CB


All times are GMT -5. The time now is 08:57 AM.