LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-20-2003, 07:21 PM   #1
lavabomb
LQ Newbie
 
Registered: Nov 2003
Location: GI, NE
Distribution: Redhat 9
Posts: 13

Rep: Reputation: 0
Grub "root=" errors, Serial ATA, kernel 2.4.22


I'm new to Linux and am trying to install Redhat 9 on my WD Raptor (a Serial ata drive). I have a D865PERL mobo from Intel (ICH5 serial ata controler). I have booted into legacy mode, and installed Redhat. I complied the 2.4.22 kernel from the source. When ever I attempt to boot the drive in legacy or enhanced mode (enhanced enables serial ata) i get the same error:

VFS: Cannot open root device "LABEL=/" or 00:00
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount fs on 00:00

I can boot Redhat in legacy mode with the stock kernel 2.4.20-8 with the "root=LABEL=/". Is this a kernel problem and i need to recompile? or is this a arguement problem with "root="? or am i totally wrong? If you know of any way i could test the 2.4.22 kernel i complied to make sure it's working that would be helpful, or if you could tell me straight up how to fix it...that works too.

Thanx in advance for the help,
Lavabomb
 
Old 11-20-2003, 10:01 PM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Does it properly detect your drives? ie do you see them in kernel debug messages
Have you created an initrd?
 
Old 11-20-2003, 10:10 PM   #3
lavabomb
LQ Newbie
 
Registered: Nov 2003
Location: GI, NE
Distribution: Redhat 9
Posts: 13

Original Poster
Rep: Reputation: 0
It's confusing

Ya it reads the WD Raptor as hdc when in legacy or hde when in enhanced, and i can see it load the ICH5 drivers too. I have NO clue wtf is goin on, aka: Newbie

Thanx for the suggestion

PS: it does have an initrd
 
Old 11-20-2003, 10:22 PM   #4
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
You need compile the module for your IDE controller as a module, if you compiled it inside the kernel the initrd wont work(or should I say is not necessary)
Try manually editing the /etc/fstab and the root= option in /boot/grub/grub.conf so that it points to hdc or hde, if this works then maybe you compiled it inside the kernel. Make sure you have a bootable redhat(or something like knoppix) CD handy so if by chance something stuffs up you can undo the changes.
 
Old 11-20-2003, 10:56 PM   #5
lavabomb
LQ Newbie
 
Registered: Nov 2003
Location: GI, NE
Distribution: Redhat 9
Posts: 13

Original Poster
Rep: Reputation: 0
I tried to point it at "root=/dev/hde" when it was in enhanced, no luck there, so i'll try the module stuff and get back tomorrow. Thnx again
 
Old 11-20-2003, 11:03 PM   #6
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Did you update /etc/fstab?
 
Old 11-20-2003, 11:14 PM   #7
lavabomb
LQ Newbie
 
Registered: Nov 2003
Location: GI, NE
Distribution: Redhat 9
Posts: 13

Original Poster
Rep: Reputation: 0
<- true newbie, I didn't know i had to edit the /etc/fstab. I just edited the "root=" in Grub before i booted it
 
Old 11-20-2003, 11:35 PM   #8
lavabomb
LQ Newbie
 
Registered: Nov 2003
Location: GI, NE
Distribution: Redhat 9
Posts: 13

Original Poster
Rep: Reputation: 0
btw, what would i have to change in /etc/fstab?
 
Old 11-21-2003, 03:47 AM   #9
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
a typical entry for a root filesystem without usnig LABELs looks like this:

/dev/hda1 / ext3 defaults 1 1
 
Old 11-21-2003, 08:12 AM   #10
lavabomb
LQ Newbie
 
Registered: Nov 2003
Location: GI, NE
Distribution: Redhat 9
Posts: 13

Original Poster
Rep: Reputation: 0
Oops

Ya, i changed it to that...or something like it, i guess i did somethin wrong cause it's not bootin up. I tried to edit the /etc/fstab with knoppix but couldn't figure out how to enable writing privilages. I think i'm just gonna reinstall to save me the trouble and try to recomple the kernel with ide as a module like you suggested.
 
Old 11-21-2003, 08:14 AM   #11
lavabomb
LQ Newbie
 
Registered: Nov 2003
Location: GI, NE
Distribution: Redhat 9
Posts: 13

Original Poster
Rep: Reputation: 0
and i think i just did /dev/hda, no 1 for the partition, Oops.
 
Old 11-21-2003, 08:32 AM   #12
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
You probably need to umount it then remount it with readwrite option in Knoppix
something like:
su

umount /dev/hda1

mount -t ext3 -o rw /dev/hda1 /mnt/some/mountpoint
 
Old 11-21-2003, 12:23 PM   #13
Mikhail_16
Member
 
Registered: Oct 2003
Distribution: Gentoo rules them all
Posts: 279

Rep: Reputation: 31
here is how my files look like (on gentoo):

fstab:
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/hda1 /boot ext2 noauto,noatime 1 1
/dev/hda3 / ext3 noatime 0 0
/dev/hda2 none swap sw 0 0
/dev/hdb1 /home ext3 noatime 0 0
/dev/hdb2 /home/httpd ext3 noatime 0 0
/dev/hdb3 /var/lib/mysql ext3 noatime 0 0
/dev/cdroms/cdrom0 /mnt/cdrom iso9660 noauto,ro 0 0
proc /proc proc defaults 0 0

grub.conf:

default 0
timeout 10
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title gentoo
root (hd0,0)
kernel (hd0,0)/boot/bzImage root=/dev/hda3

title gentoo new
root (hd0,0)
kernel (hd0,0)/boot/bzImage.new root=/dev/hda3

Hope this helps.

EDIT******************
Almost forgot here is lilo.conf from a different system:

prompt
timeout=50
default=linux
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
message=/boot/message
linear

image=/boot/vmlinuz
label=linux
read-only

image=/boot/vmlinuz.old
label=old
read-only

image=/boot/vmlinuz-2.4.20-8
label=redhat
initrd=/boot/initrd-2.4.20-8.img
read-only
append="root=LABEL=/"

Last edited by Mikhail_16; 11-21-2003 at 12:25 PM.
 
Old 11-21-2003, 04:53 PM   #14
lavabomb
LQ Newbie
 
Registered: Nov 2003
Location: GI, NE
Distribution: Redhat 9
Posts: 13

Original Poster
Rep: Reputation: 0
I got impatient and reinstalled Redhat.
I recompiled the kernel and edited the grub config and /etc/fstab.
I haven't tried enhanced mode yet but it does boot with the kernel i compiled, but my mouse won't work...if it's not one thing it's another....

You have any ideas how to get my mouse to work? (It's a 3 button USB optical with a scroll wheel)

Thanx again
You guys have really helped
 
Old 11-21-2003, 04:54 PM   #15
lavabomb
LQ Newbie
 
Registered: Nov 2003
Location: GI, NE
Distribution: Redhat 9
Posts: 13

Original Poster
Rep: Reputation: 0
It boots in legacy mode mode just fine. I think should have clerified that
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
newbie question: whats the difference between "su root", "su" and "su -&quo mojarron Slackware 9 12-07-2009 05:08 PM
FC4 install errors, "diabling IRQ #10" "nobody cares" error message??? A6Quattro Fedora 6 07-20-2005 01:49 PM
"Disabling IRQ 16" - Linux doesn't like my Serial ATA Mikessu Linux - Hardware 0 08-14-2004 12:54 PM
"make-kpkg --revision=foo.1.0 kernel_image" gives some errors (kernel 2.6.3) Duukkis Debian 14 05-23-2004 04:58 AM
help. ATA/SCSI Serial-ATA error: "ATA: Abnormal Status" xin Linux - Hardware 10 09-05-2003 11:59 PM


All times are GMT -5. The time now is 04:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration