LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   grub question changing boot order making windows boot first (http://www.linuxquestions.org/questions/linux-newbie-8/grub-question-changing-boot-order-making-windows-boot-first-280342/)

nfsutim 01-20-2005 09:12 PM

grub question changing boot order making windows boot first
 
g'day how can i make it so that instead of fedora core 3 loading atuomatically, windows loads instead?

in other words i want windows to boot first (countdown 5,4,3,2,1 thingo)
i really need to know how to do this asap plz!!!

so heres the question properly:
how to change the boot sequence in grub changing order: linux windows to windows linux.

i had it right until i did a automatic kernel update via up2date which changed it god damn it.

AltF4 01-20-2005 09:29 PM

Re: grub question changing boot order making windows boot first
 
to boot the 3rd menu entry as default modify /boot/grub/menu.lst:

Code:

e.g.
color white/blue ....
default 0
gfxmenu (hd0,0)/boot/message
timeout 10
...
title linux
 kernel ....
...
title linux2
 kernel ....
..
title windoof
...

change the "default" option :

Code:

...
default 3
...


rgiggs 01-20-2005 09:32 PM

in /boot/grub/menu.lst, change or add this line
Code:

default n
where n is a number position of your windows entry, starting from 0.

rgiggs 01-20-2005 09:35 PM

Re: Re: grub question changing boot order making windows boot first
 
Quote:

Originally posted by AltF4
to boot the 3rd menu entry as default modify /boot/grub/menu.lst:

Code:

e.g.
color white/blue ....
default 0
gfxmenu (hd0,0)/boot/message
timeout 10
...
title linux
 kernel ....
...
title linux2
 kernel ....
..
title windoof
...

change the "default" option :

Code:

...
default 3
...


it should be default 2. (starting from 0)

nfsutim 01-20-2005 09:36 PM

i guess this is located in the root directory also i forget to tell u that grub is in mbr not on a partition.

nfsutim 01-20-2005 09:39 PM

thx guys ill try it now have to reboot as im in windows
also what is the easiest way to get games working in fedora core 3? thx!!!!!!!!! :)

rgiggs 01-20-2005 09:40 PM

Quote:

Originally posted by nfsutim
also i forget to tell u that grub is in mbr not on a partition.
this is not a problem. you're only modifying the configuration file--sometimes you don't see a menu.lst but you see a grub.conf--that grub will read.

nfsutim 01-20-2005 11:39 PM

did not work proberly did something wrong anyhow here is the file can u tell me what it should be?
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,1)
# kernel /vmlinuz-version ro root=/dev/hda3
# initrd /initrd-version.img
#boot=/dev/hda
default=3
timeout=5
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.10-1.741_FC3)
root (hd0,1)
kernel /vmlinuz-2.6.10-1.741_FC3 ro root=LABEL=/
initrd /initrd-2.6.10-1.741_FC3.img
title Fedora Core (2.6.9-1.667)
root (hd0,1)
kernel /vmlinuz-2.6.9-1.667 ro root=LABEL=/
initrd /initrd-2.6.9-1.667.img
title windows xp
rootnoverify (hd0,0)
chainloader +1

nfsutim 01-21-2005 01:04 AM

i changed it and winxp now boots first only problem now is that grub dont show up at all i changed to things the lines are marked ith a ?
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0) ?
# kernel /vmlinuz-version ro root=/dev/hda3
# initrd /initrd-version.img
#boot=/dev/hda
default=3
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz ?
hiddenmenu
title Fedora Core (2.6.10-1.741_FC3)
root (hd0,1)
kernel /vmlinuz-2.6.10-1.741_FC3 ro root=LABEL=/
initrd /initrd-2.6.10-1.741_FC3.img
title Fedora Core (2.6.9-1.667)
root (hd0,1)
kernel /vmlinuz-2.6.9-1.667 ro root=LABEL=/
initrd /initrd-2.6.9-1.667.img
title windows xp
rootnoverify (hd0,0)
chainloader +1

rgiggs 01-21-2005 03:02 PM

change the splashimage line back to (hd0,1). this might fix the "grub not showing up" problem. and --did you read my previous post?-- change default to 2 to make windows boot first.

OmnipotentOscar 01-21-2005 06:58 PM

As for games have a look at the wine project... open source :D

nfsutim 01-21-2005 08:11 PM

i will try and thanks hoppefully it aint hard to set up

nfsutim 01-25-2005 05:02 PM

works thks

comhead 09-13-2007 09:27 PM

Gdday Newbie
 
Try this, go to your /boot/grub directory on your boot drive ie (hda or hdb) and edit a file called menu.lst, it's only in Ascii so you cant do any harm (make a copy b4 u start). You will need to login as root so you can save your changes! Now look for these 2 entries on the first few lines



timeout 10
default 1

Pretty simple stuff really timeout is the number of seconds the system waits

"default 1" is the title number in the menu of the program you wish to launch ie,

title Fedora 7
root (hd0,0)
makeactive
chainloader +1

title Fedora failsafe
root (hd0,0)
makeactive
chainloader +1


title Your menu option
root (hd0,0)
makeactive
chainloader +1

Please note the first title entry is 0 & then 1,2,3 etc

So if you wanted "Your menu option" to load first after 20 seconds you would change the entries to:

timeout 20
default 2

Hope this helps
email if you need any help nigelrptaylor@hotmail.com

Regards

k_goos 03-17-2010 03:10 PM

file missing
 
i have a question i go to my /boot/grub/

and there is no file caled grub.config or menu.lst


All times are GMT -5. The time now is 04:51 PM.