LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-05-2014, 12:25 AM   #1
jim.thornton
Member
 
Registered: May 2007
Posts: 404

Rep: Reputation: 19
GRUB not working -- Default highlighted but timeout doesn't auto-select


My server went down today and was down for hours while I was away from home. This is critical since it is my email server. I couldn't figure out what it was and I went to dnswatch.info so see if it was resolving correctly and it was timing out on the final set which was for my nameserver.

I VNC'd into my box and there it was sitting on GRUB. On boot I have to go into VNC and manually hit "enter" on the properly highlighted option. I can't figure out how to fix this and would really appreciate any help I can get please.

Ubuntu 12.04 LTS
Server environment
GRUB 1.99-2

contents: /etc/default/grub
Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=2
GRUB_RECORDFAIL_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
contents: /boot/grub.cfg
http://pastebin.com/rZF1utRJ
 
Old 01-05-2014, 10:30 AM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
Have you tried running update-grub to see if that corrects the problem?

The unplanned shutdown may have corrupted the grub boot files.

Last edited by bigrigdriver; 01-05-2014 at 10:32 AM.
 
Old 01-05-2014, 04:32 PM   #3
jim.thornton
Member
 
Registered: May 2007
Posts: 404

Original Poster
Rep: Reputation: 19
Yes, I have run that but it did not fix anything.
 
Old 01-05-2014, 04:54 PM   #4
jim.thornton
Member
 
Registered: May 2007
Posts: 404

Original Poster
Rep: Reputation: 19
It must have been a corrupt GRUB Boatloader because I re-installed it and it worked perfectly.

During the process of trying to fix it I added:

GRUB_RECORDFAIL_TIMEOUT=0

Should I leave that there?
 
Old 01-06-2014, 12:39 AM   #5
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
There's an article at statusq.org which has this to say about values for GRUB_RECORDFAIL_TIMEOUT:
Quote:
On the most recent Ubuntu versions (12.04 with updates, and later) you can add a setting to /etc/default/grub:
GRUB_RECORDFAIL_TIMEOUT = 30

for a 30 second timeout after it has recorded a failure condition. You can use 0 if you donít want it to pause and show the boot menu at all, but remember that it could then go into fairly fast repeated reboots if something really does go wrong.
So, it's your choice.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Select doesn't seem to be working right. errigour Programming 19 10-07-2011 10:44 AM
[SOLVED] GRUB Won't Timeout and Auto-Boot Unless Keyboard Is Plugged In recursionisrecursion Linux - Newbie 3 09-11-2011 10:28 AM
[SOLVED] Grub timeout is not working procfs Linux - Newbie 16 05-04-2009 01:26 AM
Setting GRUB default timeout duration Pax Digita Linux - Newbie 2 04-13-2006 03:21 PM
grub doesn't auto-load kernel, time/date auto-change, k3b cannot load kenji1903 Red Hat 16 03-27-2005 09:48 PM


All times are GMT -5. The time now is 08:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration