LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-19-2004, 05:41 PM   #1
digipsythe
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
GRUB Non-Gui boot


I accadently messed up GRUB so that it now no longer comes up GUI. That is unfortunate but not really crucial.

What bothers me is now everytime I want to boot into Win2k I have to type in:
rootnoverify (hd0,0)
makeactive
chainloader +1
boot


It doesnt bother me too much, I am used to it but it does get to the ball and chain.

Just wondering if there is a way to automate this so that I just have to press one thing.

Or even better if I can get it to boot into Win2k unless I give it some other input (the way it used to be)

Sorry for such a newb question, Thanks in advance.

Chance

Last edited by digipsythe; 04-19-2004 at 06:20 PM.
 
Old 04-19-2004, 06:02 PM   #2
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
Yeah...

turn the pc on so you get the prompt 'grub >'
and give the command 'root' with no parameters.
this will tell you what default root is.

if its anything like mine, it will be (hd0,0)
which translates to /dev/hda1 (mounted as /boot/ on my system after bootup)

anyway..... Boot linux, have a look inside the grub root partiton (/boot/ ?)
there is a grub folder correct ?

inside the grub folder there is a file called 'menu.lst'

slap in there whatever you want to boot...

the syntax is as follws

Quote:
default 0
timeout 0
title Windows
rootnoverify (hd0,0) (the windows disk)
chainloader +1 (use windows own boot-loader)
title Some_Linux_DIstro
root(hd0,0) (the disk and partiton where the kernel lives)
kernel /path/to/vmlinuz ro root=/dev/(linux root partiton)
initrd /path/to/initrd (optional)

leave out the boot command.
 
Old 04-19-2004, 06:19 PM   #3
digipsythe
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Original Poster
Rep: Reputation: 0
I forgot to let you all know something.

I deleted the linux partitions w/fdisk before I could think about it. (I know I know) I needed the HD space and acted before thinking.

Anyways so now the linux boot partition is gone. Win2k still loads fine when i type in those strings listed above, I just want to make it always boot into win2k. And then when I get my second hdd ill install linux over there.

Thanks in advance.
 
Old 04-19-2004, 06:32 PM   #4
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
lol.....

OKAY........

boot to the "grub>" prompt.
use the "root" command without any parameters to find out what grubs root disk and partition is.

on that disk and partiton you need to create a config file, in you case a file with 2 lines......

Quote:
rootnoverify (hd0,0)
chainloader +1
now you need to set the config file for grub to use......
which is easy with a linux distro, or knoppix cd.

god knows how you are going to do it !

boot into grub> and read help for anything to do with chainging the default config file.
 
Old 04-19-2004, 06:35 PM   #5
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
ahh, "help configfile" gives the answer.

configfile /path/to/config/file

but i dont think the change is perminent.
you need the program grub-install to write the changes to the MASTER BOOT RECORD.

is there a win32 version of grub-install ?
if there isnt, you are skrewed.
knoppix will sove this porblem, if u have the bandwidth to download a 700mb iso.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gentoo : grub: The file /boot/boot/grub/stage1 not read correctly Boudewijn Linux - Software 3 05-21-2008 04:13 AM
need to access /boot/grub/menu.lst and /boot/grub/device.map neouto Linux - Newbie 8 09-04-2005 12:45 PM
Setting password on grub, wha to do after changing default values in /boot/grub/menu. sarajevo Linux - Security 1 08-17-2005 09:01 PM
Grub setup problem (/boot/grub/stage1 not found) davidas Debian 2 04-28-2004 09:13 PM
Trying to dual-boot XP and RH9 with GRUB...GRUB stops right after BIOS EvilYoda Linux - Newbie 5 06-20-2003 04:38 PM


All times are GMT -5. The time now is 06:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration