Go Job Hunting at the LQ Job Marketplace
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 06-01-2009, 09:30 PM   #1
LQ Guru
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,084

Rep: Reputation: 336Reputation: 336Reputation: 336Reputation: 336
Grub Issues with USB install-solved

What's up gang?
OK, Today I was playing with my new TC-1.4.3-USB with grub or syslinux

Well, the other day I had installed grub to my 2GB USB and wanted to use my 4GB USB instead.
I formatted my USB ext3, set boot flag and copied tc,etc to USB
I then unhooked my HD and installed Grub to USB using Ubuntu-SE livecd

"sudo grub"
grub> "root (hd0,0)"

Usually I would get a prompt here saying-
filesysytem ext2 etc etc etc
So, I tried-
grub> "setup (hd0)"

OK, that worked and it installed correctly....
I rebooted and-

Now, then, some background-
Earlier in the day I had changed by BIOS boot order from



I changed the boot order back to-

and Grub booted up fine!!

Weird huh?
For reference my PC is a HP Pavillion AMD Athlon64 3300+ 2.4Ghz
So, another grub problem solved.
Did anyone else know about this or similar quircks with Grub??
Old 06-02-2009, 12:50 AM   #2
LQ Newbie
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0

Might be a bit off the point but would some kind soul please point me in the direction of a really good "grub primer"

Thanks Des.
Old 06-02-2009, 01:51 AM   #3
LQ Veteran
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 13,630

Rep: Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393
Might depend on your definition of "good", but here you can grab the manual.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu - GRUB install issues xavierkress Linux - Newbie 4 12-24-2007 12:52 PM
Grub 0.97 issues on slackware - grub-install is very slow, & updating menu.lst fails dieyouspammer Linux - Software 1 02-27-2006 02:06 PM
grub issues with new Gentoo install RedShirt Linux - Newbie 3 02-02-2006 08:28 AM
Solved -- grub-install "/dev/hdx does not have any corresponding BIOS drive" error jlinkels Linux - Software 2 01-10-2006 09:33 AM
grub issues/yoper install failed. rossAINTfakin Linux - Newbie 3 08-27-2004 02:50 PM

All times are GMT -5. The time now is 06:48 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration