LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-01-2009, 08:30 PM   #1
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,058

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Grub Issues with USB install-solved


What's up gang?
OK, Today I was playing with my new TC-1.4.3-USB with grub or syslinux

Well, the other day I had installed grub to my 2GB USB and wanted to use my 4GB USB instead.
I formatted my USB ext3, set boot flag and copied tc,etc to USB
I then unhooked my HD and installed Grub to USB using Ubuntu-SE livecd

"sudo grub"
grub> "root (hd0,0)"

Usually I would get a prompt here saying-
filesysytem ext2 etc etc etc
Instead NOTHING
uh-huh?
So, I tried-
grub> "setup (hd0)"

OK, that worked and it installed correctly....
I rebooted and-
"Error2"!!!

Now, then, some background-
Earlier in the day I had changed by BIOS boot order from
HD
Floppy
CDROM

TO-

Floppy
CDROM
HD

I changed the boot order back to-
HD
Floppy
CDROM

and Grub booted up fine!!

Weird huh?
For reference my PC is a HP Pavillion AMD Athlon64 3300+ 2.4Ghz
So, another grub problem solved.
Did anyone else know about this or similar quircks with Grub??
 
Old 06-01-2009, 11:50 PM   #2
dsharpd
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
Hi,

Might be a bit off the point but would some kind soul please point me in the direction of a really good "grub primer"

Thanks Des.
 
Old 06-02-2009, 12:51 AM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,206

Rep: Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015
Might depend on your definition of "good", but here you can grab the manual.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu - GRUB install issues xavierkress Linux - Newbie 4 12-24-2007 11:52 AM
Grub 0.97 issues on slackware - grub-install is very slow, & updating menu.lst fails dieyouspammer Linux - Software 1 02-27-2006 01:06 PM
grub issues with new Gentoo install RedShirt Linux - Newbie 3 02-02-2006 07:28 AM
Solved -- grub-install "/dev/hdx does not have any corresponding BIOS drive" error jlinkels Linux - Software 2 01-10-2006 08:33 AM
grub issues/yoper install failed. rossAINTfakin Linux - Newbie 3 08-27-2004 01:50 PM


All times are GMT -5. The time now is 06:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration