LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-19-2016, 10:35 PM   #1
sparkyguy
LQ Newbie
 
Registered: Feb 2004
Location: St.Louis
Distribution: Red Hat 7.3
Posts: 8

Rep: Reputation: 0
Smile Grub intercepts the use of ODD on the windows system w/Ubuntu Kylin


1. I have removed Ubuntu Kylin 14.4 from my WIN10 dual boot system.
2. I want to replace Ubuntu Kylin with Fedora Workstation 23.
3. I can get WIN10 to boot. When I enter 'exit' in Grub beta2.
4. Grub (I suspect) is preventing the use of the computer's ODD.
5. Thus, preventing the use of DVDs(Installation Disk, Repair Disk
or DiskPart Disk).
6. Can and/or how can I remove Grub from the computer to reinstall
Fedora 23?
Thanks, in advance for the assistance or help.
 
Old 01-19-2016, 11:59 PM   #2
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
The choice of boot device is made in BIOS/UEFI. Whatever boot loader is found on the boot device will be loaded. In your case hard drive is booted and since it has GRUB on it that's what is loaded.
 
Old 01-20-2016, 08:39 AM   #3
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,869

Rep: Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247
Quote:
I have removed Ubuntu Kylin 14.4 from my WIN10 dual boot system.
It would have been simpler to simply boot your Fedora installation medium and install it to the same partition(s) on which you had Ubuntu.
The Grub bootloader isn't preventing access to the BIOS, so something else is going on.
 
Old 01-20-2016, 07:00 PM   #4
sparkyguy
LQ Newbie
 
Registered: Feb 2004
Location: St.Louis
Distribution: Red Hat 7.3
Posts: 8

Original Poster
Rep: Reputation: 0
Question

Quote:
Originally Posted by yancek View Post
It would have been simpler to simply boot your Fedora installation medium and install it to the same partition(s) on which you had Ubuntu.
The Grub bootloader isn't preventing access to the BIOS, so something else is going on.
Thanks, yancek. The fedora reload was an after-thought, but, without the optical disk drive not excepting any disks, this prevents me from repairing MBR, initiating any install dvd, or using Linux repair modules. When system is rebooted, even with the ODD listed first in the bios, Grub is the 1st thing that comes up, not reading from the ODD. So, I need to get the odd reading 1st to install Fedora in the partition that Ubuntu was in. Any specific commands in limited bash that could accomplish that?
 
Old 01-20-2016, 07:58 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
dose hitting the F2 button during the very early boot ( tap it every 0.5 sec. for 15 to 30 sec.) should bring up the settings

the optical disk drive SHOULD!!! be the very first booting medium
then the first primary hard drive , then a second drive
 
Old 01-20-2016, 08:15 PM   #6
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
The media in ODD must be bootable, otherwise boot process will default to something else.
 
Old 01-20-2016, 08:53 PM   #7
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,869

Rep: Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247
Is your windows 10 installed EFI? Try disabling or turning off anything related to hibernation/fast boot, make sure you have a 64-bit Fedora although I think it's possible but not easy with 32bit and when you go to boot make sure you boot EFI, if in fact you are using EFI. I don't use Fedora but it should have an option to boot EFI.
 
Old 01-21-2016, 12:37 PM   #8
sparkyguy
LQ Newbie
 
Registered: Feb 2004
Location: St.Louis
Distribution: Red Hat 7.3
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks, people. To reply to your statements: Yes, all the media put in the ODD was bootable. My machine is x64, and was primariy a WIN 10 machine. The Grub program is the 1st thing that comes up and by entering 'exit' it goes directly to windows boot up, but the ODD never powers-up upon booting. So, I know its not accessing the drive. MS tech ask me to try msconfig and click on 'boot' tab. It only has one entry for windows 10, grub is not anywhere.
 
Old 01-21-2016, 12:39 PM   #9
sparkyguy
LQ Newbie
 
Registered: Feb 2004
Location: St.Louis
Distribution: Red Hat 7.3
Posts: 8

Original Poster
Rep: Reputation: 0
I will try the F2 scenario and see what I get.
 
Old 01-22-2016, 11:35 AM   #10
sparkyguy
LQ Newbie
 
Registered: Feb 2004
Location: St.Louis
Distribution: Red Hat 7.3
Posts: 8

Original Poster
Rep: Reputation: 0
Upon trying F2, all it does is takes me into Bios change, and I have been-there-done-that. Putting the ODD 1st in the list does nothing to improve the situation.
 
Old 01-22-2016, 11:43 AM   #11
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
The optical drive may be faulty, how about putting your install ISO to a USB stick as a workaround.
 
Old 01-31-2016, 10:32 PM   #12
sparkyguy
LQ Newbie
 
Registered: Feb 2004
Location: St.Louis
Distribution: Red Hat 7.3
Posts: 8

Original Poster
Rep: Reputation: 0
Emerson, I tried the USB device to boot from and it bypassed and went to the Grub2 2.2 beta 2-9 screen for selection. So, I think if I could remove grub and get back to booting windows; maybe odd & usb drive will start working again. I then could install Fedora 23. repair discs & installation discs will not work currently. So, unless I format the hdd, I'm stuck.
 
Old 01-31-2016, 11:10 PM   #13
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
So is it UEFI boot or not?
 
Old 02-01-2016, 03:52 AM   #14
MrTux
Member
 
Registered: Dec 2015
Posts: 131

Rep: Reputation: Disabled
Why not format the ubuntu's partition then install fedora from scratch?
 
Old 02-01-2016, 09:49 AM   #15
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,869

Rep: Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247
Quote:
So, I think if I could remove grub and get back to booting windows; maybe odd & usb drive will start working again.
Grub code is and always has been only on a hard drive with some code either in the MBR and on the Linux partition or in the EFI partition and on the Linux partition. So Grub can't interfere with your BIOS.

You still haven't answered whether windows 10 is EFI. If it was pre-installed then it almost certainly is. If you installed it, then you would know which you used. If you are using GPT partitioning, then windows will need to be EFI. You could try downloading the bootinfoscript on a Linux Live CD and running it and posting the output here. Right now, we are just guessing.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Ubuntu Kylin 15.10 Screenshot Tour LXer Syndicated Linux News 0 10-26-2015 02:10 PM
LXer: Ubuntu Kylin 15.04 Makes It Easier for Windows Users to Adapt to the Unity Interface LXer Syndicated Linux News 0 02-28-2015 12:00 PM
LXer: Ubuntu Kylin 14.10 Utopic Unicorn : Adds New Features and Improve the System Stability LXer Syndicated Linux News 0 11-10-2014 02:31 PM
LXer: Ubuntu Kylin 14.04 LTS Aims to Take Over Windows XP in China, HP Is on Board LXer Syndicated Linux News 0 05-16-2014 09:03 PM


All times are GMT -5. The time now is 02:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration