LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-29-2008, 04:43 PM   #1
dale504
LQ Newbie
 
Registered: Jan 2008
Location: IL
Distribution: f8
Posts: 29

Rep: Reputation: 15
grub help!


I installed fedora 8 on a dell with a 250gig hard drive I put fedora on the last 117gig of space now I get error from grub error2 and no boot of course!
any one know how I can fix this problem? pls help!!

thanks
dale504
 
Old 02-29-2008, 05:35 PM   #2
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Where did you install grub?
Try this;
go into your BIOS and reset the IDE hard-drive settings from (Auto) to a DMA mode the hard-drive does not recognise, e.g. On the following two motherboards, Asus A8V Deluxe and Asus A7V 880, the hard-drives are seen automatically and the drives set according to the reported back DMA mode is auto-selected (using Seagate Barracuda 120gb, 250gb, and 320gb ATA {also known as PATA} 16mb cache drives are seen as UDMA modes 5 and 6, and Hitachi Deskstar 80gb.
Set the value to one NOT recognised by the drive (ignore motherboard modes) and set them to UDMA 4, if your drive uses DMA4 or UDMA 4 use a lower value or adjust accordingly.
This will force the grub loader to read the relevant DMA/UDMA mode directly from the drive and not from the motherboard BIOS, so it then selects the correct mode and can read the drive. (If it trys to read from the motherboard BIOS it stalls and this is where the problem [BUG] occurs.

Last edited by alan_ri; 02-29-2008 at 05:41 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
grub failed to load linux (grub think ext3 partition as fat) khairilthegreat Linux - Newbie 7 08-09-2007 01:12 PM
GRUB menu.lst/grub.conf file with multiple partitions dasy2k1 Linux - General 1 04-19-2007 09:42 AM
/grub/menu.lst file disappeared but computer still boots (grub) rrrssssss Linux - General 5 04-08-2007 10:02 AM
Booting my new ubuntu install = "GRUB GRUB GRUB GRUB GRUB" etc. dissolved soul Ubuntu 2 01-13-2007 01:55 PM
Why grub prompt after installing Grub inder Debian woody 3.0r2? velan Debian 1 04-20-2004 05:55 AM


All times are GMT -5. The time now is 08:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration