LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-16-2004, 04:58 PM   #1
StraitFaced
Member
 
Registered: Oct 2004
Posts: 31

Rep: Reputation: 15
Grub HELP!


I just did a fresh install of RH9. When grub boots it doesn't do anything. It sits there on "grub>". I took a look at /boot/grub/grub.conf and everything looks normal.

When I try to mount "root (hd0,0)". It tells me that "Selected disk does not exist". And a similar error when trying to load the kernel manually.

Any suggestions?
 
Old 12-16-2004, 07:03 PM   #2
bossfrog
LQ Newbie
 
Registered: May 2004
Location: USA
Distribution: Fedora Core 3
Posts: 10

Rep: Reputation: 0
Straitfaced,

If you installed grub on the first sector of your boot partition rather than on the Master Boot Record (mbr), that might cause your problem. If you can boot from a Red Hat 9 emergency boot floppy (made at the time of installation or subsequently with "mkbootdisk"), that would tend to confirm that suspicion. If you have already installed grub on the mbr, then I don't know what the problem is.
 
Old 12-16-2004, 09:57 PM   #3
StraitFaced
Member
 
Registered: Oct 2004
Posts: 31

Original Poster
Rep: Reputation: 15
Actually problem solved. I checked the bios because that I read if the bios was confused, so would grub. The main HDD was on the secondary ide cable. So I switched the ide cables on the motherboard and grub loaded right away. Thanks for the post though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting of raw ISO from GRUB/LILO (though preferably GRUB) Orkie Linux - Software 28 12-15-2013 10:37 PM
Setting password on grub, wha to do after changing default values in /boot/grub/menu. sarajevo Linux - Security 1 08-17-2005 09:01 PM
Grub setup problem (/boot/grub/stage1 not found) davidas Debian 2 04-28-2004 09:13 PM
Why grub prompt after installing Grub inder Debian woody 3.0r2? velan Debian 1 04-20-2004 05:55 AM
1st HDD = RH9.0 (grub) ... How do I modify grub when adding 2nd hard disk ? Onyx^ Linux - Software 1 09-05-2003 10:16 AM


All times are GMT -5. The time now is 08:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration