LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   GRUB hangs after RH9 install with dual boot config (http://www.linuxquestions.org/questions/linux-newbie-8/grub-hangs-after-rh9-install-with-dual-boot-config-165199/)

AXR23 04-01-2004 09:36 PM

GRUB hangs after RH9 install with dual boot config
 
I just installed RH9 on a system that had Windows XP. I put in a new IDE drive and installed RH9 on it. I created Linux partitions on /hdb, leaving /hda to Windows. For boot loader, I selected GRUB to be placed in MBR on /hda.

On reboot after the install, it displays GRUB and nothing else, it just hangs. Subsequent reboots get the same result. So now I can't get to either OS.

Booting with Windows CD and trying to repair it doesn't seem to work.

I suppose I could reinstall Windows, and I do have data backups, but I'd rather not reinstall everything. Is there any way to restore MBR so that it boots Windows?

Any info on this will be greatly appreciated.

wiBo 04-01-2004 09:40 PM

" Is there any way to restore MBR so that it boots Windows? "

-Yes, boot with a Windows boot disk (floppy..) and type :

fdisk /mbr

newbieapr2004 04-07-2004 08:36 PM

Wooow.... I just tried to install linux today and I exactly have the same problem and still haven't resolved it. I thought that was my post !

I didn't have have floppy drive to begin with, but to restore the windows, I put the XP installation CD and do repair, went to the windows and type fixmbr at c:\windows. I had the windows up again, but still no success on the linux. Please share if you are more ahead from me.....

Thanks,
Maria

KurtStam 04-25-2004 09:18 PM

If you add a new IDE drive you need to enable this in the BIOS. Probably as the second primary device. Right now it simply cannot find your newly installed linux distribution. Hold down the F2 function key and enable the drive. Quick and simple.


All times are GMT -5. The time now is 06:32 PM.