LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 03-09-2004, 11:13 AM   #1
silversurfer
LQ Newbie
 
Registered: Mar 2004
Posts: 2

Rep: Reputation: 0
Question Grub Fails after installing new IDE disk


I am having some trouble with GRUB

I have installed RH Fedora Core 1 to a SCSI disk

Boot = /dev/sda1
Root =/dev/sda3
Swap =/dev/sda2

after getting the system up and running I added 4 IDE disks connected to a HPT370 controller card ( no RAID just as 4 independent ATA drives) after I restart the system fails to boot I get

Grub loading

Stage 1.5


and nothing else


Anybody got any Ideas ?


Thanks
 
Old 03-09-2004, 05:41 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,592

Rep: Reputation: 188Reputation: 188
Before you get the "Grub loading" message does the BIOS pass control to the HPT secondary BIOS and does the HPT secondary BIOS report the presence of the four IDE drives by manufacturer and model number?

If not, you may have to configure your motherboard BIOS to tell it about the presence of the HPT secondary IDE controller card.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 03-11-2004, 10:29 AM   #3
silversurfer
LQ Newbie
 
Registered: Mar 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Smile Found The Problem

The SCSI bios was geting overuled by the HPT370

Fixed that now works fine

Thanks for the poke in the right direction JailBait
 
Old 03-11-2004, 11:18 AM   #4
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,592

Rep: Reputation: 188Reputation: 188
"The SCSI bios was geting overuled by the HPT370"

Now that you have things working what is the order in which the various BIOS run at hardware initialization during boot?

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites

Last edited by jailbait; 03-11-2004 at 11:20 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub fails after installing new MoBo pbogaart Linux - Newbie 29 02-03-2006 05:49 PM
Installing GRUB to a floppy disk obnascar Linux - Newbie 1 08-25-2005 03:36 PM
GRUB fails to install on sata disk with Ubuntu 5.04 nonutopia Linux - Software 5 08-16-2005 04:09 AM
Installing grub onto sata drive to redirect to ide in Suse 9.3 d3viant Linux - Hardware 2 06-21-2005 10:14 AM
Installing an IDE disk BiR Linux - Hardware 2 09-09-2003 04:06 AM


All times are GMT -5. The time now is 09:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration