LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-20-2005, 08:35 PM   #1
Brightbrute
LQ Newbie
 
Registered: Dec 2005
Posts: 3

Rep: Reputation: 0
Grub error 15 after Slackware install.


I recently installed Slackware linux over an old install of Ubuntu. I chose to reformat the partition and such. Now when I boot I get:

Grub loading....

Grub Error 15

The only way I got to boot was using an Ubuntu Live CD but i'm not sure how to get rid of Grub and use the default LILO with Slackware instead. Thanks.

Edit: After searching in Slackware instead, I see that booting into recovery console on a WinXP disk and running FIXMBR should work?

Last edited by Brightbrute; 12-20-2005 at 08:51 PM.
 
Old 12-20-2005, 09:23 PM   #2
Brightbrute
LQ Newbie
 
Registered: Dec 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Ok, I tried that and the recovery asked me for what Windows I wanted to boot into and apparently I don't know my own administrator password Is there any other way to redo the MBR?
 
Old 12-21-2005, 08:31 AM   #3
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
Quote:
Originally Posted by Brightbrute
Ok, I tried that and the recovery asked me for what Windows I wanted to boot into and apparently I don't know my own administrator password Is there any other way to redo the MBR?
I think this should work :

1. boot the system using the 1st cd of the slackware.
2. at the promt write #linx root=/dev/hdxy ro
....where x = a ( if your hard disk is primary master )
x = b ( if your hard disk is primary slave )
x = c ( if your hard disk is secondary master )
x = d ( if your hard disk is secondary slave )

and y = the partition number which you have assigned as root.

after doing this, do
#/sbin/lilo

it should fix your problem

regards ( plz. correct me if i'm wrong )
 
Old 07-05-2011, 05:33 AM   #4
EsTaF
LQ Newbie
 
Registered: Apr 2003
Location: /Russian Federation/Moscou/Odintsovo
Posts: 27

Rep: Reputation: 16
Quote:
Originally Posted by ruudra View Post
I think this should work :

1. boot the system using the 1st cd of the slackware.
2. at the promt write #linx root=/dev/hdxy ro
Where did you find a "linx" command.
There's no that one.
from slackware dvd (after all booting):
lin{TAB} - result "0"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to remove lilo and install grub in slackware Joey.Dale Slackware 5 09-04-2009 05:30 PM
Grub error 17, and wont reinstall using grub-install! chiefreborn Linux - General 6 06-06-2007 10:29 AM
Slackware install reboots perpetually at GRUB timsch75 Slackware 8 03-18-2004 08:19 AM
Can't install slackware - stuck in grub> rzavarella Slackware - Installation 14 02-18-2004 05:52 AM
How to boot Slackware 9 (install) with Grub ? piraxter Slackware 1 03-24-2003 11:55 AM


All times are GMT -5. The time now is 11:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration