LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-30-2003, 06:59 PM   #1
Hound Passer
LQ Newbie
 
Registered: Jul 2003
Posts: 2

Rep: Reputation: 0
GRUB doesn't "see" Windows 98


I installed RedHat 9 on a seperate partition behind Win 98. However, GRUB only shows my RedHat OS, and not Win. I researched this but can't seem to find anything that makes sense. The partitions are there, so I assume the Win OS is still in tact and its a configuration prob. Any ideas? BTW Win 98 is FAT32.
 
Old 07-30-2003, 11:18 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
How about posting your grub configuration file and maybe we can see what's wrong.
 
Old 08-01-2003, 02:37 AM   #3
sem2
LQ Newbie
 
Registered: Aug 2003
Posts: 2

Rep: Reputation: 0
Does your grub-file (/boot/grub/grub.conf) contain the information to start Win98? I have Windows 2000 and Rehat 8.0 on my harddisk and my grub-file looks like this:

default=0
timeout=3
splashimage=(hd0,5)/grub/splash.xpm.gz
title Win2000
rootnoverify (hd0,0)
chainloader +1
title Red Hat Linux (2.4.18-14)
root (hd0,5)
kernel /vmlinuz-2.4.18-14 ro root=LABEL=/
initrd /initrd-2.4.18-14.img

You can edit your grub-file manually. If your Window 98 is on the first Partition, and you are missing the Start-Information in your grub-file, you can add the following 3 Lines to your grub-file (below or in front of the 4 Red Hat Linux-Lines):

title Win98
rootnoverify (hd0,0)
chainloader +1

If your Windows isn't on the first partition, you have to modify "rootnoverify (hd0,0)". Consult the manual.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo... grub problems... "/boot/grub/stage1" exists... no halo14 Gentoo 5 02-06-2011 05:50 PM
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 04:07 PM
how can i replace "lilo" with "grub"....... b0nd Linux - Newbie 5 04-18-2005 05:52 AM
GRUB bootloader spits out "GRUB hard disk error" Crampedson Linux - Software 2 01-26-2005 07:34 PM
Will "grub-install /dev/hda" kill Windows XP MBR? Zullocrit Linux - Newbie 3 09-25-2004 10:50 AM


All times are GMT -5. The time now is 06:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration