LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-04-2003, 06:17 PM   #1
euwingtham
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Rep: Reputation: 0
Exclamation Grub Crashes!


You heard me right! It crashes. When I start my computer, it usually loads up Grub, with a selection where I can choose my OS. Just this morning, Grub wouldn't show any splashscreen but just displays, "Grub " in a DOS-kind environment and my motherboard's speaker keeps beeping. I can't do anything but CTRL+ALT+DEL.

I know I'll most probably have to boot my RH9 from the CDs and run Rescue or something, but what is the exact steps? I haven't try it yet cause I dont have the CDs... will get them in 6 hours or so, and I hope someone can give me a reply by then.

Thanks.
 
Old 09-04-2003, 06:21 PM   #2
euwingtham
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Just so you know, here are my the details of my HDDs :

HDD1 : Windows XP
HDD2 : Windows XP/RH9

My computer boots Windows XP and only boots RH9 with Grub if I disconnect my HDD1 (or change the boot sequence in BIOS from HDD1 to HDD2 first).
 
Old 09-04-2003, 07:10 PM   #3
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
ok, pop in your redhat cd 1 (make sure u can boot from cd) and at the boot prompt, type linux rescue

go through the config steps, say continue when it asks to mount your hdd, and at the new prompt (which will have your redhat distro mounted) do the command chroot /mnt/sysimage

now u have full access of redhat
if u haven't modified your grub.conf file, u should have no problem reinstalling grub: use the command
grub-install /dev/hda (or /sbin/grub-install /dev/hda)

from the sounds of it, u installed grub on hdb originally, go ahead and install to hda if u don't want to unplug your hardrives all the time or want to continuously change bios settings
 
Old 09-04-2003, 10:59 PM   #4
euwingtham
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks! I managed to fix Grub like how you said... However I still can't get Windows XP to run from Grub. It gives me an error :

Unable to run invalid executable format

Or something like that. My current grub.conf is as follows :

title Windows XP
root (hd0,0)
map (0x81) (0x80)
map (0x80) (0x81)

makeactive
chainloader +1

My Red Hat is on (hd0,1) for some reason. Also just so you know, my Windows XP is in hdb1 and my RH is in hdd1.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting password on grub, wha to do after changing default values in /boot/grub/menu. sarajevo Linux - Security 1 08-17-2005 09:01 PM
Grub setup problem (/boot/grub/stage1 not found) davidas Debian 2 04-28-2004 09:13 PM
Why grub prompt after installing Grub inder Debian woody 3.0r2? velan Debian 1 04-20-2004 05:55 AM
Konqueror crashes, SuseWatcher crashes!!! bruno buys Linux - Newbie 9 10-07-2003 11:44 AM
1st HDD = RH9.0 (grub) ... How do I modify grub when adding 2nd hard disk ? Onyx^ Linux - Software 1 09-05-2003 10:16 AM


All times are GMT -5. The time now is 04:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration