LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-16-2006, 09:55 PM   #1
skishak
LQ Newbie
 
Registered: Feb 2006
Distribution: Fedora Core 6
Posts: 10

Rep: Reputation: 0
Unhappy GRUB config help


Hi, I need some help with grub.conf file. Windows XP is not booting from the GRUB bootloader and I don't know why. Here is my current grub.conf

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hda2
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz

title Fedora Core 4 (2.6.11-1.1369_FC4)
root (hd0,0)
kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.11-1.1369_FC4.img
title Windows XP SP2
rootnoverify (hd1,0)
chainloader +1

I've deleted 'hidemenu' for the obvious reason the menu didn't appear. Here is my hard drive setup;

SATA - 10gb (Windows XP, NTFS) + approx.100gb (NTFS)
IDE - hda1 /boot 100Mb + hda2 /(root) 40gb + hda3 -swap- 1gb + unpartitioned space

With the BIOS, I boot from SATA to access the GRUB menu and then Fedora. But if I select 'Windows XP SP2' from the menu this comes up;

Booting 'Windows XP SP2'

rootnoverify (hd1,0)
chainloader + 1

_

...and it just sits there, underslash blinking, before I press alt+ctrl+delete to restart. To boot Windows I change the hard drive boot priority in the BIOS from SATA to IDE.

Does anyone see the problem? Is there a way of checking if Windows is actually located in hd1,0?

Please help.
 
Old 02-16-2006, 10:12 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,834

Rep: Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820
See this from yesterday.
There will be several hundred similar ...
 
Old 02-16-2006, 10:13 PM   #3
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
This question is asked and answered here every now and then. Windows boots only from primary drive. You need to map drives in grub.conf. Search this forum for details or see Grub documentation.

Edit: one minute late
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub config Julian2005 Linux - Newbie 2 06-21-2005 12:39 PM
grub config in ubuntu linusownsme Linux - Newbie 1 05-07-2005 04:45 PM
Lunar grub config vredfreak Linux - Distributions 1 11-18-2004 12:09 AM
Grub.config help iLLuSionZ Linux - Newbie 19 11-09-2003 04:02 AM
GRUB config file me23 Linux - Newbie 3 07-17-2003 01:02 PM


All times are GMT -5. The time now is 02:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration