LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-25-2003, 12:55 PM   #1
usr
Member
 
Registered: Oct 2003
Posts: 44

Rep: Reputation: 15
grub.conf problem


I compiled the 2.4.22 kernel on RedHat 9.0 but I received Kernel panic at startup:
VFS: Cannot open root device “LABEL=/” or 00:00
Please append a correct “root=” boot option
Kernel panic: VFS: Unable to mount root fs on 00:00

I use GRUB and the grob.conf is

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,1)
# kernel /vmlinuz-version ro root=/dev/hda3
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,1)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-8)
root (hd0,1)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-8.img
title Red Hat Linux (2.4.22)
root (hd0,1)
kernel /vmlinux-2.4.22 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.22.img
title Windows XP Pro
rootnoverify (hd0,0)
chainloader +1

what is the problem on 2.4.22

P.S. initially I didn’t enabled the ext3 file system support so I had to recompile the kernel for the second time and at the “./mkinitrd ./initrd-2.4.22.img 2.4.22” command I found out that the ./initrd-2.4.22 already exists from the previous try but I didn’t know where how to remove it and after that to re-./mkinitrd it so I used the existing one for the new kernel. Is this a problem? How can I remove the existing ./initrd-2.4.22.img?

How can I fix this?

Thanks!
 
Old 10-25-2003, 03:01 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Instead of using:
root=LABEL=/

Try:
root=/dev/hda3

Where hda3 is your root partition.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
grub.conf problem ANU Linux - Software 4 01-06-2004 09:16 AM
grub.conf problem BlandoCal Fedora 23 12-12-2003 04:23 AM
Grub.conf problem BlandoCal Linux - Software 4 12-10-2003 09:05 PM
SiI680 cards and grub.conf problem prospectofdeath Linux - General 1 11-23-2003 04:50 AM
grub.conf problem taoweijia Linux - Newbie 2 09-20-2003 12:18 AM


All times are GMT -5. The time now is 05:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration