Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 09-08-2010, 03:40 AM   #16
Registered: Apr 2010
Posts: 30

Original Poster
Rep: Reputation: 1

lol ok ill see if i can clear things up a bit.

My Debian 5.0 is running off a IDE hard drive. Linux has decided to name this drive hdi.

The rest of my sata drives are /dev/sd(a,b,c,d,e,f,g,h,i,j,k).

I tell grub to boot from hdi in the startup command, yet for some reason it defaults back to hda (there is no hda device). Also, the GRUB bootloader is located on /dev/sda. This would be annoying if i decided to remove the hard drive as then i wont have any GRUB.
Old 09-08-2010, 04:40 AM   #17
LQ Guru
Registered: Oct 2003
Distribution: Fedora 25 Gnome (Wayland)
Posts: 5,132

Rep: Reputation: Disabled

according to your first posts about menu.lst you are on grub-legacy and not grub2.

do you agree?

2) I have a problem with your fdisk output....sda b c d e f g h i j k....thats 11 drives AND you have hdi...the IDE drive.


3) There have been suggestions about your mbr....IMHO your best bet is to install grub legacy into the MBR of your ide drive and change your bios to make the ide drive the first bootable disk.

Then your satas can go last.

Now if you do will need to know your ide /etc/fstab will be wrong.

but theres more to your fstab.....I can see at least one optical drive.

Can you tell us exactly how many optical drives you have?

generally speaking...its works like this for IDE optical drives or IDE drives

first master hda
slave hdb

second master hdc
slave hdd.

Now that means...for your hdi....ab cd ef gh ....hdi is master for ide controller Fifth you agree?

but I don't know of home motherboards that have so many ide controllers.

so more questions than answers sorry
Old 09-09-2010, 12:18 PM   #18
Registered: Apr 2010
Posts: 30

Original Poster
Rep: Reputation: 1
yes i have 11 sata drives and the 1 ide drive. 2 raid5 arrays .

There are 0 optical drives in the server.

i have grub version 0.97

I have the ide drive as the first boot drive in my motherboard hard drive boot order.

Last edited by MrMakealotofsmoke; 09-12-2010 at 03:37 AM.
Old 09-10-2010, 05:39 AM   #19
LQ Guru
Registered: Oct 2003
Distribution: Fedora 25 Gnome (Wayland)
Posts: 5,132

Rep: Reputation: Disabled

yeah well my dilemma was you reported post 1....about 9 SATA hard drives in raid configs and a single SATA on its own and in post 8 for fstab you reported
/dev/hdb /media/cdrom0 udf,iso9660 user,noauto 0 0

so I am just trying to confirm what is what...if you catch my drift?

2) OK so there are a number of issues as I see it?

a) why is hdi when you have only 2 IDE devices?

one optical drive and one hard drive....I am stumped on this one.

b) You have 11 sata drives ok...thats now confirmed.

You have grub legacy ....thats now confirmed.

You have boot that appears to change?.....or you are losing UUID fstab entry?

3) Maybe because of filesystem checks.....there is a delay in correctly mounting so many sata devices leading to UUID failure?

To minimise this....consider a few possible alternatives?

3a) use live cd to change the file system check parameter from your current boot number or vaule to a new value....and especially make this change to all sata devices?

3b) Look at what needs to be booted first....what is essential....what are your options?

Look at your fstab and look at not mounting certain devices so their "mounted" filesystem checks do not cause any issues?

feel free to comment

Last edited by aus9; 09-10-2010 at 05:42 AM.
Old 09-12-2010, 03:40 AM   #20
Registered: Apr 2010
Posts: 30

Original Poster
Rep: Reputation: 1
Ah the hdb is probably still in there because i sometimes use a temporary cd drive to boot a live cd to fix things when linux goes haywire.

Why its hdi and not hda is anyone's guess. Its very annoying to say the least.

its my grub boot like that changes, on the kernel option line.
Currently its : root=/dev/hdi1 ro quiet
but it sometimes changes to : root=/dev/hda1 ro quiet
Ive also tried using the UUID but it always defaults back to "root=/dev/hdi1 ro quiet".


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
annoying GRUB problem qrange Linux - Software 3 09-08-2009 09:04 AM
Booting my new ubuntu install = "GRUB GRUB GRUB GRUB GRUB" etc. dissolved soul Ubuntu 2 01-13-2007 12:55 PM
how annoying php Linux - Distributions 9 01-05-2007 09:42 PM
This is annoying..... dragon2knight Puppy 13 10-01-2006 09:02 AM
Very annoying: ^M King4lex Linux - General 4 08-25-2005 08:39 PM

All times are GMT -5. The time now is 08:13 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration