LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Grub and Windows 7 (http://www.linuxquestions.org/questions/linux-newbie-8/grub-and-windows-7-a-811167/)

Caram 05-30-2010 07:31 PM

Grub and Windows 7
 
Hello. I accidentally removed the Windows 7 Bootloader when I installed Archlinux. My setup is:
/dev/sda This had the Bootloader. Now has Grub and Archlinux
/dev/sdb This has my Windows 7 installation.

Now, I'm wondering what options I need to add to menu.lst to be able to boot my Windows 7 install.

Thanks!

(Sorry if Windows related questions aren't allowed here. Just lemme know.)

I should probably add some additional information. Right now my Windows option in Grub looks like:

title Windows
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1

Selecting this gives me BOOTMGR is missing.

syg00 05-30-2010 07:50 PM

Probably the wrong partition - recovery/vendor maybe. Let's see this from a root terminal "fdisk -l".
Win7 chainloads fine from grub - I lost hibernation (for Win7) though.

Caram 05-30-2010 08:04 PM

Quote:

Originally Posted by syg00 (Post 3986814)
Probably the wrong partition - recovery/vendor maybe. Let's see this from a root terminal "fdisk -l".
Win7 chainloads fine from grub - I lost hibernation (for Win7) though.

Here you go.

brucehinrichs 05-30-2010 08:29 PM

Quote:

/dev/sda This had the Bootloader. Now has Grub and Archlinux
By "Bootloader" do you mean the windows bootloader? If so, I would disable /dev/sda (either in the BIOS or by physically detaching the cable) and use your windows install disk to reinstall the (windows) bootloader to /dev/sdb. Powerdown, re-enable /dev/sda and your grub chainloader entry (as it is now) should allow you to boot into windows again.

Caram 05-30-2010 08:35 PM

Quote:

Originally Posted by brucehinrichs (Post 3986839)
By "Bootloader" do you mean the windows bootloader? If so, I would disable /dev/sda (either in the BIOS or by physically detaching the cable) and use your windows install disk to reinstall the (windows) bootloader to /dev/sdb. Powerdown, re-enable /dev/sda and your grub chainloader entry (as it is now) should allow you to boot into windows again.

Great, thanks. Will give it a go.

Super appreciated.

syg00 05-30-2010 08:38 PM

Let's see the menu.lst as well in that case (referring to the listing in post #3). And from the grub boot menu, get into command mode and let's see the output from
Code:

geometry (hd0)
geometry (hd1)


Caram 05-30-2010 08:59 PM

Quote:

Originally Posted by brucehinrichs (Post 3986839)
By "Bootloader" do you mean the windows bootloader? If so, I would disable /dev/sda (either in the BIOS or by physically detaching the cable) and use your windows install disk to reinstall the (windows) bootloader to /dev/sdb. Powerdown, re-enable /dev/sda and your grub chainloader entry (as it is now) should allow you to boot into windows again.

Awesome, absolutely brilliant. Did the trick just fine.

I was so afraid I would have to reinstall.


All times are GMT -5. The time now is 01:52 AM.