LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-26-2003, 05:17 AM   #1
Hollywood W
LQ Newbie
 
Registered: Feb 2003
Distribution: Red Hat 8.0
Posts: 27

Rep: Reputation: 15
Grub


I'm using grub as my boot loader. My primary disk,hda1, is Red Hat 8, and my slave,hdb1, is Windows XP(NTFS). I am sure it is hdb1 because I have mounted it on my desktop successfully.

so now I have gone into my grub.conf file and added the following:
title Windows
root (hd1,0)
makeactive
chainloader +1

saved the changes and left the name as grub.conf.
next, I reboot....
well now I select Windows instead of Red Hat...
and I get this message that says it doesn't understand my filesystem.

I have already installed the new ntfs patch on my kernel.
What went wrong and how do I fix this problem?
 
Old 02-26-2003, 05:23 AM   #2
annehoog
Member
 
Registered: Jan 2002
Location: Nederland
Distribution: RH 8 Psyche and Debian Woody
Posts: 373

Rep: Reputation: 30
first I think the second line should be
rootnoverify (hd1,0)
I would check that.
Second I think you made it quite hard on yourself by putting windows on slave, it doesn't like that
This is an example of a working grub file:
title Windows 98
hide (hd0,0)
hide (hd0,1)
unhide (hd0,2)
rootnoverify (hd0,2)
chainloader +1
makeactive

Hope it works,
Anne
 
Old 02-26-2003, 08:23 AM   #3
UnTamed
Member
 
Registered: Dec 2002
Location: Qc, Canada
Distribution: CRUX
Posts: 317

Rep: Reputation: 30
Code:
title Windows XP
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
makeactive
chainloader +1
 
Old 02-27-2003, 01:32 AM   #4
Hollywood W
LQ Newbie
 
Registered: Feb 2003
Distribution: Red Hat 8.0
Posts: 27

Original Poster
Rep: Reputation: 15
UnTamed:
Thanks soooo much, your advice worked. Now I get best of both worlds =). But I still prefer to use RedHat more because I'm still able to access my windows stuff from it. Once again, thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting of raw ISO from GRUB/LILO (though preferably GRUB) Orkie Linux - Software 28 12-15-2013 09:37 PM
Setting password on grub, wha to do after changing default values in /boot/grub/menu. sarajevo Linux - Security 1 08-17-2005 08:01 PM
Grub setup problem (/boot/grub/stage1 not found) davidas Debian 2 04-28-2004 08:13 PM
Why grub prompt after installing Grub inder Debian woody 3.0r2? velan Debian 1 04-20-2004 04:55 AM
1st HDD = RH9.0 (grub) ... How do I modify grub when adding 2nd hard disk ? Onyx^ Linux - Software 1 09-05-2003 09:16 AM


All times are GMT -5. The time now is 04:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration