Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 12-05-2005, 05:54 PM   #1
Registered: Apr 2005
Location: Ireland
Distribution: Mepis, mdk10
Posts: 39

Rep: Reputation: 15
group permissions

When ever i add myself to a group it doesnt seem to have any immediate effect. only after I reboot do I appear in the group. how do i stop this from happening? also when i type 'adduser towel401 opt' it just prints out the help file for adduser but i saw somewhere that command was supposed to add me to the group opt. manually adding the file

also i want my second harddrive to only be accessible by me, but when ever i try to set a uid in fstab it doesnt work
EXT3-fs: Unrecognized mount option "uid=500" or missing value
Old 12-05-2005, 06:35 PM   #2
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
just run newgrp as the user after having added him as root.
And it's NOT after a reboot, a logout/login would have fixed
the issue, too ;}

Old 12-06-2005, 04:43 AM   #3
LQ Newbie
Registered: Dec 2005
Posts: 1

Rep: Reputation: 0
Dear all,
I have some trouble in managing ACL entries, hope you can help me out. My problem follows:

I created a directory called ABC
I set grant to group1 and group2 this way:

setfacl -R -m g:group1:rwx ABC
setfacl -R -m g:group2:rwx ABC

then I have userJohn who belongs to group1 e userAlex to group2
If userJOHN creates a new file in directory ABC, by default NO grant is given to userALEX even though userALEX belongs to group2 which has full access to directory. It seems that directory grants have nothing to do with grants to new files inside the directory.

How could I tell LINUX that by default every file created or modified in the directory ABC must be rwx to both groups and to all users belonging to group1 and group2? In other words how could I tell LINUX that grants set to the directory always apply to all files which the directory contains.
Thank you very much.

Old 12-06-2005, 04:48 AM   #4
Registered: Jan 2005
Posts: 178

Rep: Reputation: 31
Linux native filesystems don't have uid mount option.
Old 12-06-2005, 04:58 AM   #5
Registered: Apr 2005
Location: Ireland
Distribution: Mepis, mdk10
Posts: 39

Original Poster
Rep: Reputation: 15
so i should just chmod -R 770 where the drive is mounted?
Old 12-06-2005, 05:19 AM   #6
Registered: Jan 2005
Posts: 178

Rep: Reputation: 31

At least 10 characters?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
group permissions nanjil SUSE / openSUSE 4 10-20-2005 01:51 PM
regarding group permissions zameer_india Linux - Networking 1 02-11-2005 04:07 AM
group permissions mikeghet Linux - Newbie 1 12-06-2004 03:49 AM
group permissions once Linux - Newbie 5 06-02-2002 03:09 AM
group permissions once Linux - Security 21 06-01-2002 03:57 PM

All times are GMT -5. The time now is 09:12 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration