LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-09-2006, 11:41 AM   #1
yuri_d
LQ Newbie
 
Registered: Mar 2006
Posts: 26

Rep: Reputation: 15
Greetings and a question about user environment


I am new both to linux and linuxquestions so greetings to all!

I am using CentOS which was great with mc and without X but when I installed XFCE i ran into problem with file permissions which pins down to this.
In level 3 this problem does not exist.
I login as myself (yuri) and startx.
If I open gnome-terminal and type
$ groups
admins
In fact I belong to admins, ftp, and httpd
$ groups yuri
admins ftp httpd

$echo $USER
yuri

X applications cannot access the files that they are meant to.
Now a possible clue
$su - yuri
Pass and such

$ groups
admins ftp httpd

Now X programs can access the required files if started from the same session from gnome-terminal. But not if started from launchers.

What can be missing in my user environmnet that su fixed and how to set it at X startup?

--------------------------------------
HP Proliant ML110 G2, CentOS 3.6, XFCE, LAMPS
 
Old 03-10-2006, 08:33 PM   #2
DeusExLinux
Member
 
Registered: May 2004
Location: Tampa, Fl
Distribution: Arch
Posts: 648

Rep: Reputation: 30
What programs are you trying to start from the gnome-terminal (i'll take it you get the GUI to start in runtime level 3... considentally enough, runtime 5 is gui at start..)

Are they programs any user should be able to start? or are they root-only programs?
 
Old 03-12-2006, 10:03 AM   #3
yuri_d
LQ Newbie
 
Registered: Mar 2006
Posts: 26

Original Poster
Rep: Reputation: 15
I load into level 3. Then I load XFCE manually.
The programs that do not access some files owned by httpd group, which i am the member of, are user programs. All root services are loaded at level 3 and work fine.

The system cannot see that the user is a member of secondary groups untill you do "sudo su - $USER; leafpad (or xffm, jedit, etc)"

After that the programs run fine in terminal. I do not want to load in GUI by default - it is a server. There must be a way set this environment somewhere in startup scripts but I do not know where or how. I do not want to add the user to system group either.

Advice will be very appreciated
Thank you for helping me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot start vnc server because the USER environment variable is not set izac5 Linux - Newbie 4 11-21-2009 09:10 PM
Setting up a multi-user programming environment pembo13 Linux - General 3 01-16-2006 01:21 AM
To restart user session.Gnome environment rubendarioportillo Linux - Enterprise 2 11-01-2005 12:43 AM
Custom user environment RHrulz Linux - Software 3 09-16-2003 08:28 AM
How to customize the desktop environment for a user? UddUnderline Linux - General 2 08-04-2003 03:33 AM


All times are GMT -5. The time now is 12:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration