LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-31-2003, 01:55 PM   #1
pal_o_matic
LQ Newbie
 
Registered: Jul 2003
Location: Hannover, Germany
Distribution: RedHat 9.A
Posts: 16

Rep: Reputation: 0
Question Great ... where is my fstab


Well, I managed to solve one of my probs from my last thread. Which means I can now surf the web from my RedHat. But the other big question asked there still keeps puzzling me.

I had a nice fstab file prepared to mount my Win98 partitions to. It worked. Until I rebooted. Then I saw that RH rewrote that file and thus deleted my precious mounting info.

Does anybody have any idea why that's so and how to stop that? It's annoying!
 
Old 07-31-2003, 01:57 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
hrmm, are you absolutely positive 100% sure you saved the file before exit? maybe you aren't properly using the text editor that you open the fstab file with.
 
Old 07-31-2003, 02:06 PM   #3
pal_o_matic
LQ Newbie
 
Registered: Jul 2003
Location: Hannover, Germany
Distribution: RedHat 9.A
Posts: 16

Original Poster
Rep: Reputation: 0
I used an Emacs within a console (no GUI). Yes the file was saved. There even was the backup file Emacs created for me. And I managed using that edited fstab right after fiddling with it. I.e. I could mount the newly entered partitions. But not only was the fstab changed back once I rebooted the machine, also the directories which I had created as mount points ("/c", "/d" and "/e") were gone.
 
Old 07-31-2003, 02:09 PM   #4
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
make sure u are root

type su, then gedit /etc/fstab

then u can save
 
Old 07-31-2003, 02:13 PM   #5
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
well he would have to be root regardless cause if he was non-root, he would of gotten an error message of permission denied when trying to save the file and when trying to make a folder in /mnt..
the only thing i have seen referenced to this is by disabling kudzu otherwise i don't know.

Last edited by DrOzz; 07-31-2003 at 02:15 PM.
 
Old 08-03-2003, 08:38 AM   #6
pal_o_matic
LQ Newbie
 
Registered: Jul 2003
Location: Hannover, Germany
Distribution: RedHat 9.A
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by DrOzz
the only thing i have seen referenced to this is by disabling kudzu otherwise i don't know.
How do I do that?
 
Old 08-04-2003, 04:39 PM   #7
pal_o_matic
LQ Newbie
 
Registered: Jul 2003
Location: Hannover, Germany
Distribution: RedHat 9.A
Posts: 16

Original Poster
Rep: Reputation: 0
Oh, and another curious fact about those mounts: I create the directories which serve as mount points, then I mount the partitions. So far, so good, so tasty.

So why is it I cannot write to any of those mounted partitions unless I am root. Oh, I get it, the access rights to those directories are write-only for non-roots (or rather: non owners).

Well, hey, I am root, ain't I? So it should be a piece of pie changing those rights? Yeah, or so I thought. Redhat just laughs and tells me that I am not allowed to change the rights to write access? Then what am I root for?

So. What do I do now?
 
Old 08-04-2003, 04:49 PM   #8
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
What are you mounting? Certain filesystems don't support permissions, so they're "stuck" on certain permissions. You specify permissions for these by putting "umask=<number>" in the options of fstab. Whatever permissions you specify here applies to everything in the filesystem.
 
Old 08-04-2003, 05:01 PM   #9
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Assuming you're talking about the Win98 before with a FAT32 filesystem? - as aaa mentioned you need a umask value in the relevant /etc/fstab line.

A umask value of 000 should be sufficient.

(just substitute in your Partition and Mount point in place of my example ones)

/dev/hda1 /mnt/windows vfat defaults,umask=000 0 0

Last edited by Skyline; 08-04-2003 at 05:07 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 07:15 AM
Well, great. skipr Linux - Security 1 10-19-2005 08:09 AM
newbie vs fstab. fstab wins :( blop Linux - Newbie 3 01-07-2005 06:54 AM
this great! halo14 General 6 11-24-2004 09:34 AM
(version 5.1 chapter 08 fstab) vs (man fstab) rgiggs Linux From Scratch 2 06-03-2004 06:55 PM


All times are GMT -5. The time now is 12:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration