LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-01-2005, 10:13 PM   #1
devbro
Member
 
Registered: Jul 2005
Posts: 74

Rep: Reputation: 15
graphical login problem


Hey everyone
I installed linux for two month and have a major problem with graphical login:
If i login graphically as root it is done with no problem.
If i login graphically using other users, the screen flickers and goes back to graphical login page.
If I login using console and execute startx here is the error that I get:
/////////////////////////////////////////
hostname: Unknown host

hostname: Unknown host
xauth: (stdin):2: bad display name "/unix:0" in "add" command
xauth: (stdin):3: bad display name "/unix:0" in "add" command

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: SuSE Linux [ELF] SuSE
Current Operating System: Linux DEVIL 2.6.11.4-21.7-default #1 Thu Jun 2 14:23:14 UTC 2005 x86_64
Build Date: 22 March 2005
Before reporting problems, check ____________
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul 30 14:04:25 2005
(==) Using config file: "/etc/X11/xorg.conf"
(WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1) found
Could not init font path element /usr/X11R6/lib/X11/fonts/local, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID, removing from list!

waiting for X server to shut down
//////////////////////////////////////////////////


The funny part is that my graphical card is located on AGP1:0:0 not PCI1:0:1

so for the only solution that i found to fix my problem is to delete the user and add it again which not convinent At all.

Can someone give me ideas where to look for a solution.
BTW: i got suse9.3 on AMDathlon64 3000+ w/ 1GB ram and ATI radeon 9600 atlantis/sapphire 256MB
 
Old 08-02-2005, 01:03 AM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
I didn't know Devil Linux supported user login?
Why not use a real distro? Well .. scratch that, it's not what you want to hear.

It would appear the config for the user created at installation is stuffed - does it work if you create a new user a root then su into it? (Or log out and then back in as the new user?) Or does the user config get messed up again if you shut down (remember - the config is stored on a floppy by default. If there is anything wrong with the floppy the config don't work. Similarily, anything which interrupts the save config when you shut down there is also a problem.)

If you like this kind of live CD distro - may I suggest Ubuntu? It was designed for what you want while Devil was not.
 
Old 08-02-2005, 07:54 AM   #3
devbro
Member
 
Registered: Jul 2005
Posts: 74

Original Poster
Rep: Reputation: 15
Hell Simon
My distro is Suse9.3, the name of my computer is DEVIL .
anyway

I can solve the problem by deleting the user and/or add a new one. But after few days the problem shows up.
I tried to check for all config files that i got that have something to do with Xwindow but i can not find any
file except xorg.conf.

For config files that you mentioned, where are they located exactly( so that i can back them up for future)

About the floppy that you mentioned, can you give me a little details, because so far i never used a floppy
under linux (to be exact its more than a year that i used a floppy).
 
Old 08-03-2005, 10:03 AM   #4
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Quote:
hostname: Unknown host
Wouldn't this seem to be the problem? Or at least an important component of the problem?

If your computer name (hostname) is DEVIL, then why are you getting an "unknown host" error?

The only reasons I can think of are that[list=1][*] Your computer is set to override the pre-existing hostname by a hostname provided by any DHCP server you may connect to-- and the DHCP server is not providing you with a hostname (leaving you hostnameless, or "unknown"); or[*] You have not set your hostname to be associated with your "real" IP address in /etc/hosts (and SuSE is quite rightly set to open DISPLAY=DEVIL:0, not some "unknown host:0").[/list=1]

Or both.

I know it sounds weird (it sounds weird to me), but the X server is actually a network operation, even when you're only running it on localhost. Furthermore, SuSE is even more rigorously secure in terms of networking than other distros one might use (because the other distros want one to be able to actually use them, and you must trade some security for useability). So the fact that you may have a networking issue (as evidenced by that "unknown host") could well be preventing the X server from opening.

As for this:
Quote:
(WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1) found

The funny part is that my graphical card is located on AGP1:0:0 not PCI1:0:1
This looks like half a problem and half not.

The second :1 in the warning suggests that it refers to the second head of the graphics card (you know, of course, that you can attach two monitors to the card). If you are not using the second head, you will get such an "error", but it's marked as (WW) for a reason; it's really just a non-fatal warning. I thought that there might be a problem with the bus being reported as PCI rather than AGP, but I see that my logs say the same thing:

Quote:
(II) Primary Device is: PCI 01:00:0
(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
(--) Chipset RADEON 9800 SE (R350 4148) found
and my X server works fine. But of course I'm using the fglrx drivers, and not the RADEON drivers.

Which could also be your problem. What happens if you change your xorg.conf from the radeon driver to the vesa driver? Does X then start?

Last edited by motub; 08-03-2005 at 10:11 AM.
 
Old 08-03-2005, 11:39 AM   #5
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
Also, many distros do not see AGP slots as AGP, they see it as PCI. My box has a nvidia MX 440 in the only AGP slot, but my system refers to it as PCI 1:0:0. I would use /sbin/lspci to see if your card is in a PCI slot, then follow the advice above. Could be as simple as setting the card to PCI 1:0:0 and you *could* be in business.

Peace,
JimBass
 
Old 08-03-2005, 12:24 PM   #6
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Well, the AGP slot is ultimately nothing but a speeded-up, graphics-dedicated PCI slot, so it's not necessarily weird that it's reported as being called PCI 1:0:* rather than AGP 1:0:*.

But from my clipped log, you can see what I meant about "the second 1": the main head is reported as PCI 1:0:0, and the second head (which produces the error, because there's nothing connected to it, so the device is not active) is reported as PCI 1:0:1. Since devbro's log clip was even more limited, without the lines above and below the warning, we don't know if PCI 1:0:0 is reported as already existing, or whether the main card body is then found on that slot.
 
Old 08-03-2005, 11:50 PM   #7
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Originally posted by devbro
Hell Simon
My distro is Suse9.3, the name of my computer is DEVIL .
Well, the confusion is natural from this line:
Quote:
Current Operating System: Linux DEVIL 2.6.11.4-21.7-default #1 Thu Jun 2 14:23:14 UTC 2005 x86_64
... for me it puts the OS name there. Did you name your computer in the right place? (Could it be that simple? Your hostname is not properly defined?) Whatever, this is probably a good reason to put your distro name in your profile (and some idea of where in the world you are...) My LQ > Edit proifile
Quote:
anyway

I can solve the problem by deleting the user and/or add a new one. But after few days the problem shows up.
I tried to check for all config files that i got that have something to do with Xwindow but i can not find any
file except xorg.conf.

For config files that you mentioned, where are they located exactly( so that i can back them up for future)

About the floppy that you mentioned, can you give me a little details, because so far i never used a floppy
under linux (to be exact its more than a year that i used a floppy).
You've got some good advice from the others - so I'll keep my gob shut on this one for now.
Tell us how you get on.

BTW: The floppy I mentioned is specific to devil linux - it is a bootable CD distro which stores all it's configuration on a floppy. It's point is to allow linux to run inside windows - so winXP can have the benifit of a linux server or something ... what with the improvements in wine and the ntfs drivers, it would seem redundant. But I guess there are folk who want to use windows mostly and dip into linux occasionally or something ...

Last edited by Simon Bridge; 08-03-2005 at 11:54 PM.
 
Old 08-04-2005, 08:57 AM   #8
devbro
Member
 
Registered: Jul 2005
Posts: 74

Original Poster
Rep: Reputation: 15
Hey Everyone
Thank you for all your advices and comments.

Right now i am planning my debug plan for this problem as follows:
1. once it happens again i will record my computer name, ip and monitor connection
2. i would try to change my address for xwindow to use 127.0.0.1 not whatever it is given by my ISP.
3. change my xorg.conf to see if other ATI drivers would solve the problem
4. run startx using some of its flags :P

wish me luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
graphical login screen gone; GDM problem? ryancw Debian 3 06-14-2004 10:08 AM
Changin Graphical Login to command line login 3DLirio Linux - Newbie 2 10-16-2003 09:43 PM
Linux graphical login problem kbkmayya Linux - Newbie 2 07-03-2003 02:26 PM
[Newbie problem] No graphical login togp Linux - Newbie 7 05-07-2003 12:24 PM
Red Hat 7.2 graphical login problem dls10 Linux - General 4 10-27-2001 06:19 PM


All times are GMT -5. The time now is 11:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration