LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-09-2006, 09:08 PM   #1
frankie_DJ
Member
 
Registered: Sep 2004
Location: NorCal
Distribution: slackware 10.1 comfy, Solaris10 learning
Posts: 232

Rep: Reputation: 31
got my wireless card working: what now? how do i hook up?


OK I think I got my wireless card finaly working under slackware 10.2. I am using fluxbox, so I have none of those fancy tools to manage wireless conection. I am at the coffee shop, free wireless, no password necessary, I set:
Code:
iwconfig eth1 ap any 
iwconfig eth1 nwid off
and my
Code:
iwconfig
shows
Code:
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11g  ESSID:"BONANZA"  Nickname:"spanky"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:0F:66:44:44:06   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=55/100  Signal level=-68 dBm  Noise level=-81 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:26
which is OK I assume (BONANZA is their network name) but when I try to ping something, it doesn't work. In other words, everything seems to be fine, but I am not on hooked up on Net.

What am I missing?

Last edited by frankie_DJ; 09-09-2006 at 09:19 PM.
 
Old 09-09-2006, 09:31 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Looks like you're OK on the wireless side. Do you have an IP address (look at ifconfig eth1). The wireless router probably assings IPs via dhcp so you can run "dhclient eth1" and hopefully that will get you set up.
 
Old 09-09-2006, 09:48 PM   #3
frankie_DJ
Member
 
Registered: Sep 2004
Location: NorCal
Distribution: slackware 10.1 comfy, Solaris10 learning
Posts: 232

Original Poster
Rep: Reputation: 31
hi bt,

this is what ifconfig gives me:

Code:
eth1      Link encap:Ethernet  HWaddr 00:16:6F:A6:B6:33  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2023 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:147307 (143.8 Kb)  TX bytes:0 (0.0 b)
          Interrupt:17 Base address:0xc000 Memory:b0100000-b0100fff 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:63 errors:0 dropped:0 overruns:0 frame:0
          TX packets:63 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:10417 (10.1 Kb)  TX bytes:10417 (10.1 Kb)
When I run dhclient eth1 I get
Code:
bash-3.00# dhclient eth1
Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

eth1: not found
 
Old 09-09-2006, 09:58 PM   #4
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 61
What does "iwlist scan" and your /etc/network/interfaces show? I assume you've tried "ifup eth1"

Last edited by rickh; 09-09-2006 at 09:59 PM.
 
Old 09-09-2006, 10:10 PM   #5
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
It's eth1 (eth followed by the numeral 1). It looks like you have ethl (eth letter l). Or amybe it's just my lousy font that makes it look that way...
 
Old 09-09-2006, 10:22 PM   #6
frankie_DJ
Member
 
Registered: Sep 2004
Location: NorCal
Distribution: slackware 10.1 comfy, Solaris10 learning
Posts: 232

Original Poster
Rep: Reputation: 31
sorry, doublepost

Last edited by frankie_DJ; 09-09-2006 at 10:30 PM.
 
Old 09-09-2006, 10:26 PM   #7
frankie_DJ
Member
 
Registered: Sep 2004
Location: NorCal
Distribution: slackware 10.1 comfy, Solaris10 learning
Posts: 232

Original Poster
Rep: Reputation: 31
This is the output of iwlist scan:
Code:
eth1      Scan completed :
          Cell 01 - Address: 00:0F:66:44:44:06
                    ESSID:"BONANZA"
                    Protocol:IEEE 802.11bg
                    Mode:Master
                    Channel:11
                    Encryption key:off
                    Bit Rate:1 Mb/s
                    Bit Rate:2 Mb/s
                    Bit Rate:5.5 Mb/s
                    Bit Rate:6 Mb/s
                    Bit Rate:9 Mb/s
                    Bit Rate:11 Mb/s
                    Bit Rate:12 Mb/s
                    Bit Rate:18 Mb/s
                    Bit Rate:24 Mb/s
                    Bit Rate:36 Mb/s
                    Bit Rate:48 Mb/s
                    Bit Rate:54 Mb/s
                    Quality=56/100  Signal level=-67 dBm  
                    Extra: Last beacon: 824ms ago
I did ifup eth1 and it says ifup: command not found. And yes, it was
eth$(3-1)=eth1. What is ifup suppose to do? I mean according to ifconfig
that connection is up

Code:
bash-3.00# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:16:D3:41:C2:9D  
          inet addr:192.168.0.161  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5800 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5577 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5146321 (4.9 Mb)  TX bytes:1321343 (1.2 Mb)
          Interrupt:18 Base address:0x3000 

eth1      Link encap:Ethernet  HWaddr 00:16:6F:A6:B6:33  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3535 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:222432 (217.2 Kb)  TX bytes:0 (0.0 b)
          Interrupt:17 Base address:0xc000 Memory:b0100000-b0100fff 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:137 errors:0 dropped:0 overruns:0 frame:0
          TX packets:137 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0

Last edited by frankie_DJ; 09-09-2006 at 10:28 PM.
 
Old 09-09-2006, 10:40 PM   #8
frankie_DJ
Member
 
Registered: Sep 2004
Location: NorCal
Distribution: slackware 10.1 comfy, Solaris10 learning
Posts: 232

Original Poster
Rep: Reputation: 31
rickh, I don't have a file /etc/network/interfaces.Am I supposed to (I am running slackware)?
 
Old 09-10-2006, 01:05 AM   #9
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
/etc/network/interfaces is the Debian location for network configs. It isn't the same on Slack apparently. I suggest google to tell you, or you can be lazy and hope one of the Slackers drops in to tell you where the equivalent file is in Slack.

I always have to do "ifup eth1" after setting the AP/password configs for my wireless card. You have to set everything up, then have the interface brought up. You may want to restart networking, that may help. In Debian it is /etc/init.d/networking restart.

Peace,
JimBass
 
Old 09-10-2006, 02:30 PM   #10
frankie_DJ
Member
 
Registered: Sep 2004
Location: NorCal
Distribution: slackware 10.1 comfy, Solaris10 learning
Posts: 232

Original Poster
Rep: Reputation: 31
Hi JimBass,

It's not that I am lazy, but I wanted to be able to set it up quickly whenever I change location. Do I always have to go to that configuration file and reset everything when I go to a different hifi hotspot? Isn't there a faster way?
 
Old 09-10-2006, 05:19 PM   #11
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
Do you have the iwconfig program installed? If you have it, setting up can be as short as 1 command. I use different SSIDs at work and home. Both are password protected, but with iwconfig you can tell it to connect to any SSID, which ever has the strongest signal. That command with iwconfig would look like (two parts, must be root for both):
Code:
iwconfig eth1 essid any
ifup eth1
That of course assumes that eth1 is your wireless card. 2 commands doesn't seem like terribily much to me. You can use a GUI to find and select the SSID, something like KWiFiManager, but the commandline is the best tool, and also the fastest. You don't need to edit any files. Just issue those commands.

Peace,
JimBass

Last edited by JimBass; 09-10-2006 at 05:21 PM.
 
Old 09-11-2006, 01:33 AM   #12
frankie_DJ
Member
 
Registered: Sep 2004
Location: NorCal
Distribution: slackware 10.1 comfy, Solaris10 learning
Posts: 232

Original Poster
Rep: Reputation: 31
JimBass,

I don't have a ifup utility but I am assuming
Code:
ifconfig eth1 up
should work the same. So I do

iwconfig eth1 essid "whatever"

my light for wireless goes on once I do that.

Than I go

ifconfig eth1 up

When I check with iwconfig, everything seems fine, except I never got ip address assignmed to my and I can't ping anybody.

Another thing is, I can detect bunch of unsecured networks around me with

iwlist eth1 scan,

but there is only one or two for which the light goes on when I do

ifconfig eth1 up

Last edited by frankie_DJ; 09-11-2006 at 01:36 AM.
 
Old 09-11-2006, 02:04 AM   #13
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
I'm not sure what the file would be in Slackware, but in Debian it is the previously mentioned /etc/network/interfaces. Try the command given earlier, dhclient eth1 and see if that does it. That has to come after you told it what SSID you want to connect to, even if it is "any". If it doesn't, find the file where dhcp/static IP info is set, and add an entry for eth1. Chances are good the installer didn't detect it, so you most likely have no entry for your wireless card.

Peace,
JimBass
 
Old 09-11-2006, 03:56 AM   #14
frankie_DJ
Member
 
Registered: Sep 2004
Location: NorCal
Distribution: slackware 10.1 comfy, Solaris10 learning
Posts: 232

Original Poster
Rep: Reputation: 31
All right, it's working . Thanks JimBass, good job. The file that you mentioned is /etc/rc.d/rc.inet1.conf in slackware. Only my regular card had an entry in there. ALl I had to do was change this:

#Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="" <-- put "yes" here!
DHCP_HOSTNAME[1]=""

and restart inet1 with
/etc/rc.d/rc.inet1 restart

and it was up in a matter of seconds.
 
Old 09-11-2006, 07:54 AM   #15
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
Yep, that sounds like the right set up. Glad to hear it's working now. By the way, I spent some time in Eureka, CA during grad school, that was by far the most beautiful place I have ever been.

Peace,
JimBass
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless card, wireless keyboard suddenly not working Shankarrajus Fedora 1 04-06-2006 12:30 AM
Getting My Wireless Card Working? carlosinfl Debian 1 01-08-2006 01:06 PM
wireless card not working saiz66 SUSE / openSUSE 2 10-26-2005 02:39 PM
Wireless-G card only working as B? dracolich Linux - Wireless Networking 2 08-24-2005 07:05 PM
Wireless card should be working passthetwitch Linux - Hardware 3 08-18-2004 08:32 AM


All times are GMT -5. The time now is 04:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration