LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-17-2009, 01:38 AM   #1
epicmono
LQ Newbie
 
Registered: Apr 2008
Posts: 4

Rep: Reputation: 0
gOS 3.1 Gadgets does not have write permission for usb pen drives


I installed gOS 3.1 a few days ago. When I plug in my pen drive it cannot mount the device due to an error "Invalid mount option". When I sudo from the terminal and mount it manually it mounts. I can then access the drive by double clicking the icon but then I cannot edit the files in there. I don't have write option. I again have to work from the terminal as root to copy paste files in the pen drive. Can someone be very specific as to how I can solve this problem.

I read somewhere in the net that FAT32 doesn't have the ability to retain user permission information. But that's not a valid answer as almost 99% of the pen drives are in the FAT32 format.

I also read that I have to edit the /etc/fstab file somehow. But I don't understand the code and it would be helpful if u could be very specific. For example, I don't understand sda, sdb and stuff like that and how to understand which one refers to my pen drive.

Thanks in advance. I hope anyone can solve this, my friends are killing me with their mocking cause I can't make this work.


Here is my /etc/fstab file if that is of any help to you:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda2
UUID=bd95da5c-cf2c-44e6-b00f-a18efb3c0fac / ext3 relatime,errors=remount-ro 0 1
# /dev/sda3
UUID=15e77cad-0c82-4560-b3f2-124dbcb03d64 none swap sw 0 0
/dev/sdb /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sdb /media/floppy1 auto rw,user,noauto,exec,utf8 0 0


Do I need to change it in anyway?

Last edited by epicmono; 01-17-2009 at 10:02 AM. Reason: Added the /etc/fstab file
 
  


Reply

Tags
drive, gos, pen, usb


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: gOS 3.0 Gadgets ScreenShots, Looks like a MAC with Google Gadgets everywhere... LXer Syndicated Linux News 0 10-05-2008 04:50 PM
LXer: The Perfect Desktop - gOS 3.0 Gadgets LXer Syndicated Linux News 0 10-02-2008 08:42 PM
LXer: gOS 3 Gadgets (beta) targets Linux beginners and Google Gadgets lovers LXer Syndicated Linux News 0 08-16-2008 01:50 AM
LXer: gOS Announces gOS 3 Gadgets-the Newest Version of its Linux OS LXer Syndicated Linux News 0 08-07-2008 01:50 AM
MDK 10.x - Mount USB Pen OK, But no permission to write Xolo Linux - Software 2 05-20-2005 06:19 AM


All times are GMT -5. The time now is 01:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration