LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-13-2001, 08:38 PM   #1
marksstroud
LQ Newbie
 
Registered: Sep 2001
Location: Irving,TX
Distribution: Suse 7.1 Pro
Posts: 25

Rep: Reputation: 15
Unhappy Goof up in fstab!


HELP! I'm trying to mount my Zip250 parallel drive and I'm up to my neck in it.I was trying to add the line to fstab: /dev/sda4 /mnt/zip100.0 vfat noauto,user 0 0
When I attempted to reboot,I got into a repair mode under bash.I got a line:[mntent]:warning:no final new line at the end of /etc/fstab.I seem to have made the "root" only readable.I am following Iomega's instructions for mounting.I haven't recompiled the kernel yet.I have Suse Linux 7.1 Pro.I really don't know if my kernel will support it as Suse ships it.I first entered: modprobe imm.Thereafter I entered: mkdir /mnt/zip100.0.After that things went south.Do I need to do repair the damage and start over?
 
Old 10-13-2001, 10:00 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
not too familiar with zip drives, but yeah, i don't think it would be a bad idea to repair what you did and then start over.. at least edit what you changed back to before, and see if it boots up with no problems then....
 
Old 10-13-2001, 10:13 PM   #3
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
here's what mine looks like for my internal:

/dev/hdb1 /media/zip auto noauto,user 0 0

SuSE uses /media/zip instead of /mnt/zip.
 
Old 10-14-2001, 12:24 AM   #4
rolf
Member
 
Registered: Jul 2001
Location: Oakland, CA
Distribution: Mageia 5 x86_64
Posts: 186

Rep: Reputation: 33
I've run into that. Seems the config files need a newline at the end. Line feed. Return. When you edit the file and push the down arrow, the cursor goes down to the first space in an empty line after the last line of text.

In Mandrake, I boot a rescue, mount /dev/hda5 (my / partition, where resides /etc/fstab) /mnt/disk (mount point that already exists in my rescue linux) -t reiserfs (file type, probably will autodetect)

# chroot /mnt/disk
# vi /etc/fstab

man vi or info vi or help within vi gives me enough of a clue to change an entry or just get a line feed at the end of a file.

# shutdown -r now

reboots.

# halt -n

halts. HTH
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Display\Resolution settings goof... Decepticon22 Linux - General 2 11-02-2005 08:25 PM
Apt / Synaptic goof BenGoodrich Debian 3 08-16-2005 03:07 AM
Newbie Goof!! TChumley Debian 5 11-23-2004 10:34 AM
mounting goof up paragon Linux - Newbie 2 05-14-2004 11:06 AM
Help with file-type association goof for folders... Sgaileach1 Linux - Software 7 02-02-2004 03:33 PM


All times are GMT -5. The time now is 02:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration