LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-20-2003, 12:42 AM   #1
StevePhM
Member
 
Registered: Oct 2003
Distribution: SuSE10.1
Posts: 36

Rep: Reputation: 15
Gnutella not working with RH9 :(


I'm pretty new to linux so you'll have to forgive me if this is a dumb question.

I've recently installed Gnutella on my RH9 system, and I'm having difficulties making it work. The icon at the bottom of the Gnutella window is telling me that it thinks I'm firewalled (I can't remember if I set that up during the redhat installation, sorry). It says that I won't see any "push results" which means that I may miss a lot of search results.

I've seen from another thread (that has remained unfinished for a few months now so is no help) that the result from the command "/sbin/iptables -L" could be helpful, so here goes,

Chain INPUT (policy ACCEPT)
target prot opt source destination
RH-Lokkit-0-50-INPUT all -- anywhere anywhere

Chain FORWARD (policy ACCEPT)
target prot opt source destination
RH-Lokkit-0-50-INPUT all -- anywhere anywhere

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Chain RH-Lokkit-0-50-INPUT (2 references)
target prot opt source destination
ACCEPT udp -- NS1.es.net anywhere udp spt:ntp dpt:ntp
ACCEPT udp -- visserv1.slac.stanford.edu anywhere udp spt:ntp dpt:ntp
ACCEPT udp -- visserv2.slac.stanford.edu anywhere udp spt:ntp dpt:ntp
ACCEPT udp -- NS1.es.net anywhere udp spt:ntp dpt:ntp
ACCEPT udp -- visserv1.slac.stanford.edu anywhere udp spt:ntp dpt:ntp
ACCEPT udp -- visserv2.slac.stanford.edu anywhere udp spt:ntp dpt:ntp
ACCEPT udp -- dns1.lsanca.sbcglobal.net anywhere udp spt:domain dpts:1025:65535
ACCEPT udp -- dns1.snfcca.sbcglobal.net anywhere udp spt:domain dpts:1025:65535
ACCEPT udp -- NS1.es.net anywhere udp spt:domain dpts:1025:65535
ACCEPT udp -- visserv1.slac.stanford.edu anywhere udp spt:domain dpts:1025:65535
ACCEPT udp -- visserv2.slac.stanford.edu anywhere udp spt:domain dpts:1025:65535
ACCEPT udp -- anywhere anywhere udp spts:bootps:bootpc dpts:bootps:bootpc
ACCEPT udp -- anywhere anywhere udp spts:bootps:bootpc dpts:bootps:bootpc
ACCEPT all -- anywhere anywhere
REJECT tcp -- anywhere anywhere tcp dpts:0:1023 flags:SYN,RST,ACK/SYN reject-with icmp-port-unreachable
REJECT tcp -- anywhere anywhere tcp dpt:nfs flags:SYN,RST,ACK/SYN reject-with icmp-port-unreachable
REJECT udp -- anywhere anywhere udp dpts:0:1023 reject-with icmp-port-unreachable
REJECT udp -- anywhere anywhere udp dpt:nfs reject-with icmp-port-unreachable
REJECT tcp -- anywhere anywhere tcp dpts:x11:6009 flags:SYN,RST,ACK/SYN reject-with icmp-port-unreachable
REJECT tcp -- anywhere anywhere tcp dpt:xfs flags:SYN,RST,ACK/SYN reject-with icmp-port-unreachable


Can anyone help me??
 
Old 11-20-2003, 01:53 AM   #2
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Well let me tell you that you DO have a firewall (congratulations). I'm not sure what the specific problem is but I can tell you that you're better off getting a program called gift. It's got a gnutella plugin as well as fasttrack and it's own network called openft. I works really well. If however, you want to use gnutella, you can give the command iptables -F. That flushes all rules so you wont have a firewall anymore. The firewall will be restored on reboot, though so you'll have to find which program is loading it and disable it. It might be a good idea to make your own firewall.
 
Old 11-20-2003, 11:05 AM   #3
StevePhM
Member
 
Registered: Oct 2003
Distribution: SuSE10.1
Posts: 36

Original Poster
Rep: Reputation: 15
Thanks adz -- at least I know I have a firewall now!

Are there any changes I can make to the iptables that would let just the one port have unrestricted access to the net?? (I know how to change the port Gnutella uses, so it would be useful if I could open up just that one.)

Thanks for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wimewire Gnutella client works, but apollon-gnutella does not :( qwijibow Linux - Networking 3 03-14-2007 03:45 PM
gtk-gnutella Input Not Working spaaarky21 Linux - Software 3 06-27-2004 08:54 PM
Gnutella plugin for giFT is not working. Seraph Linux - Software 3 12-24-2003 07:26 AM
Gnutella not working due to rh9 firewall StevePhM Linux - Security 21 12-01-2003 03:05 AM
gtk-gnutella just stoped working ? what changed ? qwijibow Linux - Software 1 11-16-2003 04:39 PM


All times are GMT -5. The time now is 07:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration