LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-22-2015, 10:46 PM   #16
LoneTiger
LQ Newbie
 
Registered: May 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by syg00 View Post
And /etc/samba/smb.conf ?.
/etc/samba/smb.conf

Code:
LTFileServer:~# cat /etc/samba/smb.conf
[global]
  workgroup = WORKGROUP
  realm = WORKGROUP
  netbios name = LTFileServer
  server string = Personal Cloud Storage

  include = /etc/samba/smb-global.conf
  include = /etc/samba/smb-global_veto.conf
  include = /etc/samba/overall_share

LTFileServer:~#
 
Old 05-23-2015, 05:00 AM   #17
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,312

Rep: Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989
So how's the rebuild progressing ?
Code:
cat /proc/mdstat
 
Old 05-23-2015, 08:51 AM   #18
LoneTiger
LQ Newbie
 
Registered: May 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by syg00 View Post
So how's the rebuild progressing ?
Code:
cat /proc/mdstat
UI says its finished, not accessible so far through the normal means (Windows file browser) due mount error. So will try photorec on either of the drives first.

/proc/mdstat
Code:
LTFileServer:~#
LTFileServer:~# cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md3 : active raid1 sda4[3] sdb4[2]
      1948998520 blocks super 1.0 [2/2] [UU]

md2 : active raid1 sda3[2] sdb3[1]
      500724 blocks super 1.0 [2/2] [UU]

md0 : active raid1 sda2[3] sda1[1] sdb2[2] sdb1[0]
      1999808 blocks [4/4] [UUUU]

unused devices: <none>
LTFileServer:~#
 
Old 05-23-2015, 09:07 AM   #19
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,312

Rep: Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989
I would be inclined to mount it locally on LTFileServer - that would prove the filesystem is ok or not. If it is you may simply be able to copy off the data there - easier and safer. First try the "parted -l" again and see if it can ascertain the filesystem type.
 
Old 05-23-2015, 09:40 AM   #20
LoneTiger
LQ Newbie
 
Registered: May 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by syg00 View Post
I would be inclined to mount it locally on LTFileServer - that would prove the filesystem is ok or not. If it is you may simply be able to copy off the data there - easier and safer. First try the "parted -l" again and see if it can ascertain the filesystem type.
LTFileSeerver is merely the name I created under the device's UI to personalize the drive's share, remember, this is not a full linux install but a network drive that runs GNU linux to manage the RAID 1 and the filesystem on the 2x2Tb HD's in the device itself.

WD My Book Live DUO
 
Old 05-24-2015, 09:39 AM   #21
LoneTiger
LQ Newbie
 
Registered: May 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
Question

I think I managed to mount the hard and I can see something that looks like linux here...

Where would be my data be located?
The program search function just throws everything back.

*****
Here's a thought, if I connect either one of the RAID 1 hard drives to a linux computer running CentOS and not the automated GNU from the book duo, can I fix the filesystem on the hard drive so all my files and paths are accessible?
Attached Thumbnails
Click image for larger version

Name:	l1.jpg
Views:	23
Size:	155.6 KB
ID:	18552  

Last edited by LoneTiger; 05-24-2015 at 08:59 PM. Reason: Extra info.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
WD MyBook Live Duo - Raid 0 fails to mount data volume (can't find superblocks) gilsonsjc Linux - Hardware 3 06-08-2014 04:17 PM
NTFS signature is missing, trying to mount RAID-5 volume ofuser Linux - Hardware 4 10-15-2010 02:21 AM
Unable to mount additional harddrive from a RAID volume system. andrei_r20 Linux - Server 3 04-10-2010 02:04 AM
upgrade system with lvm on software raid-1 data volume w/o losing data BinWondrin Linux - General 1 01-13-2009 03:25 PM
Need to mount LVM volume and save Data -- Recovering from power loss. chuckcom Linux - General 1 02-09-2008 07:57 PM


All times are GMT -5. The time now is 12:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration