LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-23-2008, 03:42 AM   #1
FSHero
LQ Newbie
 
Registered: Jul 2007
Distribution: Kubuntu Feisty Fawn
Posts: 12

Rep: Reputation: 0
GNOME or GTK text auto-completion in file name boxes


I've had this very annoying niggle with GNOME (or GTK: I don't know what exactly I'm referring to) for a while now, and it has to be the single most important reason I prefer KDE over GNOME!

Anyway, enough babbling. I'm using Kubuntu Feisty (7.04), running Thunderbird in KDE. If I click "attach", it brings up a file name box, with the keyboard 'focus' on the text box.

If I start typing e.g "/home/fs", it will autocomplete with "/home/fshero", but with the end-part highlighted. Hence, I would still be able to type "hero" (as if to complete the name "fshero") myself.

However, I noticed that sometimes (and I can't quite figure out when systematically) when I type, it fills in the box completely automatically. So, the text 'jumps forward'. E.g. While typing "/h", it fills it with "/home", and then when I type "/f" it fills with "/home/fshero".

The only occasion where I have noticed this occurring systematically is if I press Ctrl+Tab to tab through all the options, then return back to the text-box again. Also systematic is when I select the whole text of the text box and press Backspace. After this, typing is back to 'old behaviour' (that is, the first situation I described above).

Apart from these observations, there have been times where the text box switched to the 'new' behaviour and I haven't been able to identify exactly what else does this.

The reason why this is so annoying is because I touch-type. So, when I'm typing at speed, I make mistakes with the 'new' behaviour (as I am expecting the 'old'). Thankfully I've never encountered this with any KDE dialogue boxes.

How do I turn the 'new' behaviour off with a keyboard shortcut or a permanent option? I hate having to select the text with the mouse and typing it all again!

NOTE: There are screenshots in my thread at http://ubuntuforums.org/showthread.php?t=701741
 
Old 02-23-2008, 06:43 AM   #2
catweasel28
Member
 
Registered: Mar 2007
Location: United Kingdom
Distribution: Mint, OpenSUSE,Dream
Posts: 68

Rep: Reputation: 17
Smile

You'll need to go to the Control Center>

Under the 'Look & Feel' section, there's a subsection called 'Window Behaviour'. You should be able to set the autocompletion to your preferences there.
 
Old 02-25-2008, 04:14 PM   #3
FSHero
LQ Newbie
 
Registered: Jul 2007
Distribution: Kubuntu Feisty Fawn
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by catweasel28 View Post
You'll need to go to the Control Center>

Under the 'Look & Feel' section, there's a subsection called 'Window Behaviour'. You should be able to set the autocompletion to your preferences there.
Thanks catweasel28 for the reply. I went to both GNOME and KDE's control centres, but could not find the option you were talking about. There is no "Look and feel" section in kcontrol, but there was one in GNOME's control centre. Note: I have installed the ubuntu-desktop package on top of my kubuntu-desktop package.

Furthermore, I discovered that the 'triggers' to the odd auto-completion behaviour were not correct! It seems to happen almost of its own volition. I know it sounds really bizarre, but I have no clue what triggers the behaviour change.

I now notice that pressing Ctrl+Tab to cycle through the items in the dialogue box doesn't consistently change the behaviour. It seems to me at the moment that if I hold the backspace key to clear all the text in the box, it switches to the 'unwanted' behaviour. Take this with a pinch of salt though, my experiment might have been wrong!

I now also notice that clearing the text-box using Ctrl+Home and pressing Del (not backspace) will switch the behaviour to the 'desired' one.

Could this be a bug in GNOME, Thunderbird or KDE? I also ran the GIMP and brought up an "open file" dialogue; this was even more sporadic -- I couldn't induce 'unwanted' behaviour as described above; it seemed to occur randomly.

Please help!
 
Old 02-26-2008, 04:03 AM   #4
catweasel28
Member
 
Registered: Mar 2007
Location: United Kingdom
Distribution: Mint, OpenSUSE,Dream
Posts: 68

Rep: Reputation: 17
Exclamation Another Approach

Sorry my original suggestion wasn't more helpful. I see you've had no replies to the same question on Ubuntuforums.

I can't guarantee it will help, but check out this link:

http://www.gnomefiles.org/version.php?soft_id=1263
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TAB Auto Completion rsmccain Linux - Software 6 11-20-2007 09:47 PM
jdee auto completion xeon123 Linux - Software 1 03-16-2007 06:59 PM
auto-completion in idle/idlefork? Guest1234 Programming 1 08-28-2005 04:13 PM
auto-completion in bash with wildcards juanbobo Linux - Software 2 04-07-2005 12:56 AM
auto-completion - how does it work & can my script args auto-complete? BrianK Programming 1 06-11-2004 04:51 PM


All times are GMT -5. The time now is 08:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration