LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   GNOME or GTK text auto-completion in file name boxes (http://www.linuxquestions.org/questions/linux-newbie-8/gnome-or-gtk-text-auto-completion-in-file-name-boxes-623247/)

FSHero 02-23-2008 04:42 AM

GNOME or GTK text auto-completion in file name boxes
 
I've had this very annoying niggle with GNOME (or GTK: I don't know what exactly I'm referring to) for a while now, and it has to be the single most important reason I prefer KDE over GNOME!

Anyway, enough babbling. I'm using Kubuntu Feisty (7.04), running Thunderbird in KDE. If I click "attach", it brings up a file name box, with the keyboard 'focus' on the text box.

If I start typing e.g "/home/fs", it will autocomplete with "/home/fshero", but with the end-part highlighted. Hence, I would still be able to type "hero" (as if to complete the name "fshero") myself.

However, I noticed that sometimes (and I can't quite figure out when systematically) when I type, it fills in the box completely automatically. So, the text 'jumps forward'. E.g. While typing "/h", it fills it with "/home", and then when I type "/f" it fills with "/home/fshero".

The only occasion where I have noticed this occurring systematically is if I press Ctrl+Tab to tab through all the options, then return back to the text-box again. Also systematic is when I select the whole text of the text box and press Backspace. After this, typing is back to 'old behaviour' (that is, the first situation I described above).

Apart from these observations, there have been times where the text box switched to the 'new' behaviour and I haven't been able to identify exactly what else does this.

The reason why this is so annoying is because I touch-type. So, when I'm typing at speed, I make mistakes with the 'new' behaviour (as I am expecting the 'old'). Thankfully I've never encountered this with any KDE dialogue boxes.

How do I turn the 'new' behaviour off with a keyboard shortcut or a permanent option? I hate having to select the text with the mouse and typing it all again!

NOTE: There are screenshots in my thread at http://ubuntuforums.org/showthread.php?t=701741

catweasel28 02-23-2008 07:43 AM

You'll need to go to the Control Center>

Under the 'Look & Feel' section, there's a subsection called 'Window Behaviour'. You should be able to set the autocompletion to your preferences there.

FSHero 02-25-2008 05:14 PM

Quote:

Originally Posted by catweasel28 (Post 3067130)
You'll need to go to the Control Center>

Under the 'Look & Feel' section, there's a subsection called 'Window Behaviour'. You should be able to set the autocompletion to your preferences there.

Thanks catweasel28 for the reply. I went to both GNOME and KDE's control centres, but could not find the option you were talking about. There is no "Look and feel" section in kcontrol, but there was one in GNOME's control centre. Note: I have installed the ubuntu-desktop package on top of my kubuntu-desktop package.

Furthermore, I discovered that the 'triggers' to the odd auto-completion behaviour were not correct! It seems to happen almost of its own volition. I know it sounds really bizarre, but I have no clue what triggers the behaviour change.

I now notice that pressing Ctrl+Tab to cycle through the items in the dialogue box doesn't consistently change the behaviour. It seems to me at the moment that if I hold the backspace key to clear all the text in the box, it switches to the 'unwanted' behaviour. Take this with a pinch of salt though, my experiment might have been wrong!

I now also notice that clearing the text-box using Ctrl+Home and pressing Del (not backspace) will switch the behaviour to the 'desired' one.

Could this be a bug in GNOME, Thunderbird or KDE? I also ran the GIMP and brought up an "open file" dialogue; this was even more sporadic -- I couldn't induce 'unwanted' behaviour as described above; it seemed to occur randomly.

Please help!

catweasel28 02-26-2008 05:03 AM

Another Approach
 
Sorry my original suggestion wasn't more helpful. I see you've had no replies to the same question on Ubuntuforums.

I can't guarantee it will help, but check out this link:

http://www.gnomefiles.org/version.php?soft_id=1263


All times are GMT -5. The time now is 04:07 PM.