LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-21-2004, 02:45 PM   #1
jeopardy
LQ Newbie
 
Registered: Sep 2004
Posts: 6

Rep: Reputation: 0
gnome not starting..


heya, this is my first post here. i just installed mandrake 10.1 a couple of days ago and it has been running fine even though i don't know alot about it. anyways i just ran into a really strange problem! i logged out from my account to change to root but when i logged in again the gnome loader stops at the mediaplayer i was using (was listening to mp3s from a cd and forgot to close that down before signout). i can still browse the internet through the mandrake welcome window but that is all i can do. i can not right click on the desktop and i don't have a menu of any kind anywhere.
any ideas on how to solve this?!

thanks in advance!
 
Old 09-21-2004, 06:34 PM   #2
oracleofmist
LQ Newbie
 
Registered: Sep 2004
Posts: 13

Rep: Reputation: 0
maybe there is a simpler solution but reinstall gnome and its packages
 
Old 09-21-2004, 10:44 PM   #3
Electronkz
Member
 
Registered: Mar 2004
Location: Punta del Este, Uruguay
Distribution: Fedora
Posts: 176

Rep: Reputation: 31
First, why do you want to login X as root, don´t do that, it is not safe, instead open a terminal an "su -" to root.
That being say, let look at your possible problem:
Maybe you have configured in gnome to "Restore Old Session" that is why it hangs at starting the mediaplayer that you forgot to close
Quote:
maybe there is a simpler solution but reinstall gnome and its packages
Come on!! that is a big solution for a minimal problem.
Try this instead:
1) Search for a directory named Autorun or something inside your ~/.gnome directory the .gnome directory is where gnome put all the configuration and cache files. if you find a directory similar to that there you will see maybe scripts or links to applications to launch programs at startup (only X programs),
If the above doesn´t work or you can´t find the autorun directory or it doesn´t exists, Try this:
2) Delete the .gnome/ directory in you home directory and enter again the directory will be recreated but please keep in mind that you will lose your configuration on gnome.

Note: about the Autorun directory in Gnome i don´t know much but there is one in KDE so gnome must have a similar directory or script somewhere.

After You finish remember(if you want) to change the configuration so every time you start Gnome it will start with an empty session.
Other possible solutions:
#!: run this at the command prompt: gnome-session-properties

Hope it helps, Good Luck!

Last edited by Electronkz; 09-21-2004 at 10:46 PM.
 
Old 09-22-2004, 02:59 AM   #4
jeopardy
LQ Newbie
 
Registered: Sep 2004
Posts: 6

Original Poster
Rep: Reputation: 0
First off, I wanted to log in to root because there are so many things that I can not do under my regular log in, such as when i was trying to install bittorrent and you have to add a line to /etc/mailcap. which has a writing protection on it. Now that I have actually got bittorrent to work (i reinstalled everything to remedy my earlier problem) there is the same problem, I can download files with it if I am logged in as root but if I use my normal login it just says 'Failed!" or permission denied.
So, if I am not supposed to use root as login then how do I change my regular one so that I can atleast use it for basic things like this?
 
Old 09-22-2004, 03:13 AM   #5
Haiyadragon
Member
 
Registered: Sep 2003
Location: Gorredijk, Netherlands
Distribution: Arch Linux
Posts: 400

Rep: Reputation: 30
Like Electronkz said, su to root in a terminal. Open a terminal (when logged as a normal user), type su, then your password and open up your favorite text editor like 'gedit /etc/mailcap'.
 
Old 09-22-2004, 03:20 AM   #6
jeopardy
LQ Newbie
 
Registered: Sep 2004
Posts: 6

Original Poster
Rep: Reputation: 0
okies, that part i understand, it's a bit more problematic when it comes to my bittorrent problem however. the way i usually do it is that when i find a torrent i want i just click it -> open with -> and then the path to btdownloadgui.py. this worked when i tried it while logged in as root but now it just says failed! i'm at a loss..
 
Old 09-22-2004, 03:47 AM   #7
Electronkz
Member
 
Registered: Mar 2004
Location: Punta del Este, Uruguay
Distribution: Fedora
Posts: 176

Rep: Reputation: 31
jeopardy, you´re hijacking your own post
Anyway, you´re a newbie here, so it is ok, but in the future post different problems in different threads, so if somebody run into the same problem again he can find a solution.
About the bittorrent issue, are you sure that the file btdownloadgui.py has the right permissions set.
For example do this, 1) Open a terminal
2) cd <directory_of_btdownloadgui.py>
3) ls -l #ls -l will list all the files in the directory and show you their permissions , type man ls for more information
4) now if you get something like:
-rwxrwxr-- root root btdownloadgui.py
This is how you read it: i)"-" says it is a file
ii)"r" stands for Read
iii)"w" stands for Write
iv)"x" stands for execute
v) it is divided in three sets i mean the first three letters after the "-" are talking about the owner of the file(or Directory), the second set of three letters talks about the group and the last set about the other users.
Now the first "root" name you see talks about the owner which is root in this case and the second "root" tells you that the files belongs to the group root.
Now you will want a regular user can access the python file, so you have several options:
#1: use the chmod command #man chmod for more information
ex chmod o+rwx <file> this will give other users permissions to Read, Write and execute the file.
or #2 use the chown command which changes the owner of the file #man chown for more information
ex: chown <user> <group> <file_or directory>
And please, again you should not login to X as root, by X i mean Kde or Gnome or whatever window manager you use.

Last edited by Electronkz; 09-22-2004 at 03:49 AM.
 
Old 09-22-2004, 08:54 AM   #8
jeopardy
LQ Newbie
 
Registered: Sep 2004
Posts: 6

Original Poster
Rep: Reputation: 0
oh i'm sorry. in any case, you are wonderful to take time with noobs like me. i'm still having problems but i will start those in a new thread
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome panel keeps crashing when starting gnome-session elluva Linux - Software 3 01-24-2006 05:26 PM
Starting Gnome ikkuh1991 Linux - Newbie 3 03-07-2005 10:40 AM
starting GNOME bdrevn Linux - Software 3 04-22-2004 07:28 PM
Starting gnome? smac Slackware 10 11-18-2003 02:20 PM
starting x with gnome kubicon *BSD 3 09-20-2003 12:41 AM


All times are GMT -5. The time now is 02:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration