LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-20-2005, 01:39 AM   #1
rabin r
LQ Newbie
 
Registered: Jul 2005
Location: Philippines
Posts: 5

Rep: Reputation: 0
Gnome login problem


hi all,

i installed red hat v.9x in my PC Intel Pentium IV 2.8 Ghz, and its working before i installed the XFree86. i just learned that XFree86 will "not do the graphics" on Intel 845G chipset, so i have to switch to X-accelerate.

i disabled the graphical login, and reboot the system. upon reboot, it always go to the command prompt $. my question is how can i login in the GNOME environment without going to the command prompt?

rabin
 
Old 07-20-2005, 02:18 AM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Not sure if this is what you mean, but you need to edit the /etc/inittab file (you will have to be root to do this).

There's a line that says something like

# Default runlevel.
id:3:initdefault

There's a list of runlevels above that. On Slackware, it's 4 for a graphical login, not sure about Red Hat. All you need to do is change that 3 to a 4 (or whatever it is for RH, see the file), save the file and reboot.

HTH.
 
Old 07-20-2005, 02:39 AM   #3
rabin r
LQ Newbie
 
Registered: Jul 2005
Location: Philippines
Posts: 5

Original Poster
Rep: Reputation: 0
hello Nylex,

yes, my default runlevel is already set to 3: full multiuser mode (in RH). but still i could not go directly to GNOME desktop environment.



rabin
 
Old 07-20-2005, 02:48 AM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Is there no runlevel that says something like "X11 with XDM/GDM/KDM (session managers)"?
 
Old 07-20-2005, 02:57 AM   #5
rabin r
LQ Newbie
 
Registered: Jul 2005
Location: Philippines
Posts: 5

Original Poster
Rep: Reputation: 0
these are the runlevels of inittab in RH

0 - halt
1 - single user mode
2 - Multiuser without NFS
3 - Full multiuser mode
4 - unused
5 - X11
6 - Reboot
 
Old 07-20-2005, 03:04 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Change your 3 to a 5 in inittab then.
 
Old 07-20-2005, 03:25 AM   #7
rabin r
LQ Newbie
 
Registered: Jul 2005
Location: Philippines
Posts: 5

Original Poster
Rep: Reputation: 0
my runlevel was 5 after installing XFree86. on boot up, my monitor shows white color with bigger pixels. this is due to incompatibility of XFree and my video chipset intel 845G. with this in my monitor, i changed the runlevel to 3: Full multiuser mode and monitor shows user login and then the command prompt.

before, without XFree86, upon boot up it will go directly to Gnome login and then to desktop. i want to go back in this kind of setting.

hope you understand, my english is not that good. thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[TIP] gnome-panel problem after login maginotjr Slackware 1 07-08-2005 11:31 AM
gnome login problem chingcheng Linux - Software 1 05-27-2005 04:24 AM
Gnome login problem! sfaae Linux - Newbie 2 01-25-2005 05:01 PM
Problem when login to dropline gnome jerrit Slackware 0 09-13-2004 04:04 PM
gnome login problem on rh9 buraks78 Linux - Newbie 3 10-10-2003 10:53 PM


All times are GMT -5. The time now is 12:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration