LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-13-2011, 08:40 AM   #1
Themiband
LQ Newbie
 
Registered: Mar 2011
Posts: 3

Rep: Reputation: 0
Gnomad is driving me mad


I'm trying to install Gnomad and have got this far

I type ./configure and everything looks like its kinda working then it says

"No package 'glib-2.0' found
No package 'gthread-2.0' found
No package 'libnjb' found
No package 'gtk+-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GN_CFLAGS
and GN_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details."

What on earth am i meant to do with this?
 
Old 03-13-2011, 08:46 AM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Looks like you are missing some of the development packages.
But why are you installing from source?
Why don't you just use your distro's package manager to install gnomad?
Which version (distribution) of linux are you running?
 
Old 03-13-2011, 01:39 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,632

Rep: Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267
"Old" Ubuntu : gnomad2. No gnomad in 10.04 and 10.10, AFAIK.
Quote:
No package 'glib-2.0' found
No package 'gthread-2.0' found
No package 'libnjb' found
No package 'gtk+-2.0' found
'package glib-2.0' means /usr/lib/pkgconfig/glib-2.0.pc ( "package config file".)

sudo apt-get install libgtk2.0-dev libnjb-dev

.. will provide all four files, and more : All required for building gnomad.

..

Last edited by knudfl; 03-13-2011 at 01:43 PM.
 
Old 03-13-2011, 01:58 PM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
We don't know what distro the OP is using.

But gnomad V 2.9.4-1 is in the ubuntu 10.04 ("Universe") repository.
 
1 members found this post helpful.
Old 03-13-2011, 02:47 PM   #5
Themiband
LQ Newbie
 
Registered: Mar 2011
Posts: 3

Original Poster
Rep: Reputation: 0
ok so I'm running Ubuntu 10.10 (I think anyhow)

these are my specs

00:00.0 Host bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL Memory Controller Hub (rev 0e)
00:01.0 PCI bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL PCI Express Root Port (rev 0e)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc R423 UK [Radeon X800SE (PCIE)]
01:00.1 Display controller: ATI Technologies Inc Radeon R423 UK (PCIE) [X800 SE] (Secondary)
02:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:07.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)

I've tried doing the

sudo apt-get install libgtk2.0-dev libnjb-dev

and i think thats helped (although i don't know what i've done i'm kinda curious to know). and now when i go to configure gnomad this is my new error message

and this is my new error message

configure: error: *** id3tag.h C header is needed (missing -dev package?) ***\n*** You might have erroneously installed id3lib instead of libid3tag ****\nThis distinction is very delicate, so PLEASE pay attention! ***

the other thing i've tried doing is installing Banshee and a few other things like that but none of them recognise my zen any ideas?
 
Old 03-13-2011, 03:07 PM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,632

Rep: Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267
Quote:
id3tag.h C header is needed
→ → sudo apt-cache search id3tag

sudo apt-get install libid3tag0-dev

( You can also use the (2) Search in Synaptic (Ubuntu Softwarecenter)
to find missing package names.

And @tredegar is right (post #4) : gnomad2 is available, also in 10.10.

So why not start with : sudo apt-get install gnomad2
( You may have to add "Canonical-partners" etc. in
Synaptic > Settings > Archives > Other Software.)
EDIT : Synaptic says : libmtp7 is not installable, when gnomad2 is marked for install.
EDIT EDIT http://packages.ubuntu.com/hardy/libmtp7
sudo dpkg -i libmtp7* : And you can install / use gnomad2.
..

Last edited by knudfl; 03-13-2011 at 03:24 PM.
 
Old 03-14-2011, 12:30 PM   #7
Themiband
LQ Newbie
 
Registered: Mar 2011
Posts: 3

Original Poster
Rep: Reputation: 0
Oh by god so today i've done nothing different but WHOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO!!!

i can move files onto my zen again at last

guys this is pretty freakin amazing i've been getting sick of having to listen to the same few songs and not being able to listen to my fav pod casts if any of you are in UK coventry I will buy you all a drink I am so amazingly greatful.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] KDE Is Driving Me Mad! Mulsiphix *BSD 29 12-02-2009 10:19 AM
applydeltaiso driving me mad!! Fredstar SUSE / openSUSE 4 04-30-2006 10:30 PM
kernel is driving me mad luqman Linux - Newbie 6 02-18-2005 05:05 AM
kernel is driving me mad luqman Red Hat 2 02-17-2005 07:00 AM
Samba driving me mad powadha Linux - Networking 4 06-10-2004 01:46 PM


All times are GMT -5. The time now is 07:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration