LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-22-2006, 05:10 AM   #1
pravinth
LQ Newbie
 
Registered: Nov 2006
Posts: 5

Rep: Reputation: 0
Question gmake error or gcc old version......???


Hi Friends,
I am new to linux and fedora, For my project work i have to install one simulator-there i have the problem-its not installing, when i run some ./build-3-glibc. i am getting the below error:
---------------------------------------------
checking version of gmake... 3.80, ok
configure:
error:*** These critical programs are missing or too old: gcc
*** Check the INSTALL file for required versions.
gmake: *** No rule to make target `all'. Stop.

What it means?????????????????????
--------------------------------------------
I don't know whats the problem-i sent mail to the simulator user group and has not got any reply yet.so i am posting in here to get some good peoples help...
so plaese help me-what might be the problem and how can i fix it.
Thanks in advance!

Here is the complete error reports:
----------------------------------------
when i run: ./build-1-binutils
i am getting the below error:
---------------------------------------
checking whether make sets ${MAKE}... yes
configure: error: source directory already configured; run make distclean there first
gmake: *** [configure-binutils] Error 1
-----------------------------------------


and when i run: ./build-2-gcc-core
i am getting the below error:
-----------------------------------------
gmake[1]: *** [crtbegin.o] Error 1
gmake: *** [all-gcc] Error 2
----------------------------------------


and when i run: ./build-3-glibc
i am getting the below error:
---------------------------------------
configure: error:
*** These critical programs are missing or too old: gcc
*** Check the INSTALL file for required versions.
gmake: *** No rule to make target `all'. Stop.
---------------------------------------

plz help me...Thank you!
 
Old 11-22-2006, 01:19 PM   #2
pravinth
LQ Newbie
 
Registered: Nov 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Arrow

plz help me to fix the problem....
 
Old 11-23-2006, 11:43 AM   #3
pravinth
LQ Newbie
 
Registered: Nov 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Question how can i make a MIPS2 version of gcc???

please Atleast tell me how can i make a MIPS2 version of gcc???
Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 03:54 PM
Error due to old version of gcc (probably) tandre Programming 4 04-13-2005 12:01 PM
gmake error in postgres instalation umala SUSE / openSUSE 1 04-08-2005 10:18 AM
export CC=/usr/bin/gcc-3.2 - switch gcc version? ferreter Linux - Software 1 08-20-2003 01:07 AM
Sample Driver Module incompatibility with Kernel version (or gcc version) jvs Linux - General 1 06-07-2002 02:40 AM


All times are GMT -5. The time now is 12:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration