LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-03-2004, 05:25 PM   #1
Hyper1on
LQ Newbie
 
Registered: Oct 2004
Posts: 22

Rep: Reputation: 15
Glxgears Problems with video card


Hey,all i got this messages after to have configure my graphic card and i try to run glxgears

ATI RADEON 9200SE 128mb

Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual


what im suppose to do ?

Last edited by Hyper1on; 10-03-2004 at 05:36 PM.
 
Old 10-03-2004, 05:41 PM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Do you have Load "glx"in the "Module" section of /etc/X11/XF86Config (or /etc/X11/xorg.conf)?
 
Old 10-03-2004, 05:42 PM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,965
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
Depends a bit on which distro you're using ...

It may be as trivial as editing /etc/X11/XF86Config
and loading glx in the server section ....

Or enabling dri with correct permissions.


Cheers,
Tink
 
Old 10-03-2004, 05:42 PM   #4
Hyper1on
LQ Newbie
 
Registered: Oct 2004
Posts: 22

Original Poster
Rep: Reputation: 15
no i dont know how ...
 
Old 10-03-2004, 05:48 PM   #5
Hyper1on
LQ Newbie
 
Registered: Oct 2004
Posts: 22

Original Poster
Rep: Reputation: 15
How ???
 
Old 10-03-2004, 05:57 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,965
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
Code:
Section "Module"

# This loads the DBE extension module.

    Load        "dbe"   # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

# This loads the Type1 and FreeType font modules
    Load        "type1"
    Load        "speedo"
    Load        "freetype"
#    Load        "xtt"

# This loads the GLX module
    Load       "glx"
# This loads the DRI module
    Load       "dri"

EndSection

Code:
 Section "DRI"
    Mode 0666
 EndSection

That's what my relevant sections look like...

As to how: use your favourite text editor.


Cheers,
Tink
 
Old 10-03-2004, 06:04 PM   #7
Hyper1on
LQ Newbie
 
Registered: Oct 2004
Posts: 22

Original Poster
Rep: Reputation: 15
what is this ???
 
Old 10-03-2004, 06:25 PM   #8
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,965
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
/etc/X11/XF86Config
 
Old 10-03-2004, 07:09 PM   #9
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
Why do they say this ;If you already have an X config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"
I have the same problem on some dist. and others go without a hitch,never did leave load dri in there may try that next time.
oops!

Last edited by comprookie2000; 10-03-2004 at 07:21 PM.
 
Old 10-03-2004, 07:15 PM   #10
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,965
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
Quote:
Originally posted by comprookie2000
[B]Why do they say this ;If you already have an X config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"
Probably because ATI chipsets are known
to run very poorly with nvidia drivers?


:P



Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
glxgears crashes Piwko Linux - Hardware 1 08-24-2005 09:37 PM
glxgears question zeroz52 Linux - Newbie 3 03-13-2005 04:46 AM
glxgears canyon289 Linux - Hardware 8 02-27-2005 01:14 PM
glxgears lock up slacka Linux - Hardware 2 10-10-2004 10:40 PM
GLXgears bug??? CryptDragoon Linux - General 1 03-07-2004 10:14 PM


All times are GMT -5. The time now is 07:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration