LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-04-2014, 12:38 PM   #1
MarXindia
LQ Newbie
 
Registered: Mar 2014
Posts: 3

Rep: Reputation: Disabled
Smile GLIBC_2.14 not found during Houdini installation


Hello,

I am new to linux and after alot of googling around I was able to install Sidefx Houdini in my system but when I am trying to start it It gives me the error :

/opt/hfs13.0.198.21/bin/houdini-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/libHoudiniAPPS3.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/libHoudiniAPPS3.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/libHoudiniAPPS2.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/libHoudiniAPPS2.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/libHoudiniUI.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/libHoudiniUI.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/libHoudiniUI.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/libHoudiniUT.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/libHoudiniUT.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/libHoudiniUT.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libjemalloc.so.1)
/opt/hfs13.0.198.21/bin/houdini-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniOPZ.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniOPZ.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniOP3.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniOP3.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniOP2.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniOP2.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniOP1.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniOP1.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniSIM.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniSIM.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniGEO.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniGEO.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniAPPS1.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniDEVICE.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniPRM.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libHoudiniPRM.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libopenvdb_sesi.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libtbb.so.2)
/opt/hfs13.0.198.21/bin/houdini-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libboost_thread-gcc46-mt-1_51.so.1.51.0)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libfreetype.so.6)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libtiff.so.4)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libPtex.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libxml2.so.2)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libxml2.so.2)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libboost_regex-gcc46-mt-1_51.so.1.51.0)
/opt/hfs13.0.198.21/bin/houdini-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libboost_regex-gcc46-mt-1_51.so.1.51.0)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libdwelf.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libz.so.1)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/././libcollada_dae.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/././libboost_program_options-gcc46-mt-1_51.so.1.51.0)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/././libosdCPU.so.2.1.0)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/././libAlembicAbc.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/././libAlembicAbcGeom.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/././libAlembicAbcCoreAbstract.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/././libIex.so.10)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libjpeg.so.62)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./libiconv.so.2)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/././libtbbmalloc.so.2)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./././libAlembicAbcCoreOgawa.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./././libAlembicAbcCoreHDF5.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/./././libAlembicUtil.so)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/././././libhdf5_hl.so.7)
/opt/hfs13.0.198.21/bin/houdini-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/hfs13.0.198.21/bin/../dsolib/././././libhdf5.so.7)


Sorry If I pasted whole log thought Itw`d be required to understand the problem better.Now,for what I have read in forums its not suggested to overwrite the current version of GLIBC i.e, 2.12 there are some options provided in some of the forums regarding installing the newer version into a seperate directory and linking it(which I have no idea about)... any help will help.

Thanks
 
Old 06-04-2014, 01:23 PM   #2
potato_farmer
Member
 
Registered: May 2014
Posts: 55

Rep: Reputation: Disabled
It is possible that the version of the package you installed requires a newer GLIBC than your distribution can provide. There may be another version of the application better suited for your environment.

What OS and version are you running?
 
Old 06-04-2014, 01:35 PM   #3
MarXindia
LQ Newbie
 
Registered: Mar 2014
Posts: 3

Original Poster
Rep: Reputation: Disabled
Angry

I am using Centos 6.5. And I cannot downgrade my Application version as it has alot of new upgrades which I am using.
 
Old 06-04-2014, 01:48 PM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
@MarXindia : Welcome to LQ.

Glibc is your OS (together with the kernel),
and cannot be updated / replaced.

If you want to use that specific version of "Houdini" : Install a later OS.

Or use an older version of Sidefx Houdini.
( The first Linux version was released 15 years ago.)

-
 
Old 06-04-2014, 01:55 PM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 3 .

CentOS 6.x is Fedora 12 based.

Suggest :
Install Fedora 20 on a spare partition / a spare hard disk.

Or wait half a year for CentOS 7.

-
 
Old 06-04-2014, 02:04 PM   #6
MarXindia
LQ Newbie
 
Registered: Mar 2014
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by knudfl View Post
@MarXindia : Welcome to LQ.

Glibc is your OS (together with the kernel),
and cannot be updated / replaced.

If you want to use that specific version of "Houdini" : Install a later OS.

Or use an older version of Sidefx Houdini.
( The first Linux version was released 15 years ago.)

-
Hello and thank you knudfl.This forum has a lot of knowledge I`ll try to grab as much as I can into my bank.

Now, I can`t use older versions of Houdini because of the critical improvement in speed and performance of volume fluids which I am using currently.Moreover,at my office Houdini 13(version Iam trying to use)is already installed in Centos 6.5.But, IT dept there is not very helpful to tell me how .Though,when I checked the GLIBC version of the OS at office.its 2.12 only not modified.I think they are using the same installing glibc_2.14 in a different directory and linking it to houdini(not sure);
PS: I have already tried upgrading GLIBC_2.12 to 2.14 in my Home system.I surely got rid of the GLIBC_2.14 not found errors but the others errors mentioned were still there.Also by doing that I ended up reinstalling my OS as the problems started with firefox crashing and few other errors.(It was fun though)
 
Old 06-04-2014, 06:25 PM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 6 .

Yes, you can of course create glibc-2.14 with a hide away location :
../glibc-2.14.x/configure --prefix=/opt/glibc214 --<other-options>.
http://archive.linuxfromscratch.org/...r06/glibc.html
** Or much better : Get a copy of the files that your colleges are using.

About "GLIBCXX_3.4.15" : That's an object in libstdc++-6.so.6.0.16
( or later ) from gcc-4.6.x .

-
 
Old 06-04-2014, 06:36 PM   #8
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 2,324
Blog Entries: 1

Rep: Reputation: 447Reputation: 447Reputation: 447Reputation: 447Reputation: 447
You could create a chroot with a newer distro version and install and use the application in the chroot. I had a similar GLIBC issue. Debian wheezy comes with 2.13.x and certain java based games require 2.14.x or later to be able to play with OpenGL support. In my case I upgraded to testing, but it's just a desktop.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
glibc_2.4 not found?? can't install software!!! gvp87 Linux - Software 0 08-05-2007 12:31 PM
[For Help] 'GLIBC_2.3' not found eNsEmpire Linux - Software 0 03-13-2007 10:39 PM
version GLIBC_2.3 not found when starting Apache proco Linux - Software 3 09-23-2006 07:08 AM
GlibC_2.3 not found message when .configure shazam75 Linux - Software 0 10-15-2004 04:33 AM
version 'GLIBC_2.3' not found BadGuy Linux - Software 2 02-24-2003 08:50 AM


All times are GMT -5. The time now is 04:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration