LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-09-2003, 02:28 PM   #1
genoa
LQ Newbie
 
Registered: Jul 2003
Posts: 9

Rep: Reputation: 0
glibc-2.2.4.i386.rpm (Red Hat 7.1)


I need to upgrade my glibc package to 2.2.4 for an installation of another package.

However, after downloading glibc, common and development I attempted to use rpm to install each one and each one gave me a dependency error.

Each one says it needs the others in version 2.2.4 or greater, however if I can't install any of them how am I supposed to provide that dependency?


# rpm -i glibc-2.2.4-19.i386.rpm
error: failed dependencies:
glibc-common = 2.2.4-19 is needed by glibc-2.2.4-19
glibc-devel < 2.2.3 conflicts with glibc-2.2.4-19
glibc > 2.2.2 conflicts with glibc-common-2.2.2-10
# rpm -i glibc-common-2.2.4-19.i386.rpm
error: failed dependencies:
glibc < 2.2.4 conflicts with glibc-common-2.2.4-19
# rpm -i glibc-devel-2.2.4-19.i386.rpm
error: failed dependencies:
glibc = 2.2.4 is needed by glibc-devel-2.2.4-19

Any suggestions?
 
Old 07-09-2003, 03:55 PM   #2
genoa
LQ Newbie
 
Registered: Jul 2003
Posts: 9

Original Poster
Rep: Reputation: 0
BTW, --nodeps just spews out a bunch of lines containing files and install conflicts with 2.2.2.
 
Old 07-09-2003, 04:05 PM   #3
genoa
LQ Newbie
 
Registered: Jul 2003
Posts: 9

Original Poster
Rep: Reputation: 0
Nevermind. I did a rpm -Uvh and all three package names on the same line and it worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem installing glibc-2.3.2-4.80.i686, glibc-common-2.3.2-4.80.8.i386.rpm martianpackets Red Hat 8 05-01-2009 04:22 PM
glibc problem Red Hat 8.0 rahowill Red Hat 3 10-20-2005 11:06 PM
Red Hat i386 32 bit upgrade to Red Hat IA64 bit louisb Linux - Enterprise 4 10-08-2005 02:28 AM
update glibc-2.3.5-6.i386.rpm jupiter3437 Linux - General 3 05-25-2005 05:11 AM
does anybody know where I can get glibc-devel-2.3.2-5.i386.rpm. kelly_kong03 Linux - General 1 06-02-2004 12:59 PM


All times are GMT -5. The time now is 02:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration