LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-18-2006, 06:23 AM   #1
zivs
Member
 
Registered: Jan 2005
Location: Ogre, Latvia
Distribution: Ubuntu 9.10
Posts: 72

Rep: Reputation: 15
GLIB - two versions. how to remove oldest?


So here's the full story: I was trying to install install Xchat 2.6.4 (not Xchat-gnome 0.11 which was i found via synaptic), but was receiving errors about no >=2.0.3 versions. Ok, installed through synaptic 2.10.3 version and later from gtk.org 2.8.0 version. And now is the next problem:
------------------------------------------------------------
checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.0.3...
*** 'pkg-config --modversion glib-2.0' returned 2.8.0, but GLIB (2.10.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: "Cannot find glib"
root@zivs-desktop:/home/zivs/Desktop/xchat-2.6.4#
------------------------------------------------------------
And yes, trying to do this on fresh Ubuntu 6.06 installation
What should (and how) I do to remove that 2.10.3 version?
Thanks in advance
 
Old 06-18-2006, 07:10 AM   #2
kickzha
LQ Newbie
 
Registered: Sep 2004
Location: augsburg homeboy
Distribution: debian sarge/sid
Posts: 17

Rep: Reputation: 0
...im not very familiar with ubuntu...but in short my thoughts...

I cannot talk about ho to configure pkg-config - but i think the Problem is as follows:

You got different versions of Libraries in your /usr/lib Directory, and i think (have a look at the man) ldconfig links the newest lib-Versions it founds to the approprieta library.

But your pkg-config (/usr/lib/pkd-config/glib-2.0.pc) says different, ldconfig found.

So the answer to your Question? - i dont know, if you compiled the 2.8 from gtk.org-sources it's problematic. If you installed from a tarball, it's problematic - i think.

But older version doesn't have to be removed i think, only if it's akin you, or just to get free space.

Why did you install 2.8 later on to 2.10 ??

Maybe the 2.10 version you cannot deinstall because it's the recommended package to your distribution-version ??

--

If so, try to reconfigure libglib2.0-dev, may be
Code:
dpkg-reconfigure libglib2.0-dev
and check what
Code:
pkg-config --modversion glib-2.0
will say...i hope that gives 2.10.3...then the configure-Script of Xchat should run, with glib-2.0 v. 2.10.3 .


regards
kickzah

Last edited by kickzha; 06-18-2006 at 08:37 AM.
 
Old 06-18-2006, 07:42 AM   #3
zivs
Member
 
Registered: Jan 2005
Location: Ogre, Latvia
Distribution: Ubuntu 9.10
Posts: 72

Original Poster
Rep: Reputation: 15
I can't really say why i installed 2.8.. maybe just because wanted the latest version
So i tried dpkg-reconfigure, but got this message:
--------------------------------------------------
root@zivs-desktop:/home/zivs# dpkg-reconfigure libglib2.0-dev
Package `libglib2.0-dev' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: libglib2.0-dev is not installed
root@zivs-desktop:/home/zivs#
--------------------------------------------------
and pkg-config --modversion says that it is 2.8.0 version

I was thinking about removing that 2.10.3 from synaptic, but it wants to remove alot of applications with it...

Last edited by zivs; 06-18-2006 at 09:23 AM.
 
Old 06-18-2006, 12:52 PM   #4
kickzha
LQ Newbie
 
Registered: Sep 2004
Location: augsburg homeboy
Distribution: debian sarge/sid
Posts: 17

Rep: Reputation: 0
Talking

Quote:
Originally Posted by zivs
I can't really say why i installed 2.8.. maybe just because wanted the latest version
So i tried dpkg-reconfigure, but got this message:
--------------------------------------------------
root@zivs-desktop:/home/zivs# dpkg-reconfigure libglib2.0-dev
Package `libglib2.0-dev' is not installed and no info is available.
...seems its called other way...or really not installed?
Quote:
Originally Posted by zivs
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: libglib2.0-dev is not installed
...try
Code:
dpkg -l libglib* | grep ii
Quote:
Originally Posted by zivs
root@zivs-desktop:/home/zivs#
--------------------------------------------------
and pkg-config --modversion says that it is 2.8.0 version

I was thinking about removing that 2.10.3 from synaptic, but it wants to remove alot of applications with it...
...that i was thinking about...

I conclude u didn't have installed libglib2.0-dev, and tried to go the way with gtk.org/gnome.org.

Maybe
Code:
apt-get install libglib2.0-dev
would have done the act, and will do it right now too. Test it!

Last edited by kickzha; 06-18-2006 at 12:53 PM.
 
Old 06-18-2006, 01:09 PM   #5
zivs
Member
 
Registered: Jan 2005
Location: Ogre, Latvia
Distribution: Ubuntu 9.10
Posts: 72

Original Poster
Rep: Reputation: 15
Thanks for helping - libglib2.0-dev helped me out, but had an errors with perl so we (had a little help from friend over IRC) disabled it for the installation. all works fine
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 02:35 AM
Two Fluxbox Versions - Root starts newest,User starts oldest fortezza Linux - Software 1 05-21-2006 01:17 AM
2 different versions of glib and pkgconfig! karl0s Linux - Software 4 09-01-2004 06:05 AM
Two versions of Glib? OnlyMe Linux - Software 1 04-21-2004 06:13 AM
2 versions of glib conflict toships Linux - Newbie 2 02-21-2004 03:29 PM


All times are GMT -5. The time now is 10:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration