LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   GLIB - two versions. how to remove oldest? (http://www.linuxquestions.org/questions/linux-newbie-8/glib-two-versions-how-to-remove-oldest-455906/)

zivs 06-18-2006 06:23 AM

GLIB - two versions. how to remove oldest?
 
So here's the full story: I was trying to install install Xchat 2.6.4 (not Xchat-gnome 0.11 which was i found via synaptic), but was receiving errors about no >=2.0.3 versions. Ok, installed through synaptic 2.10.3 version and later from gtk.org 2.8.0 version. And now is the next problem:
------------------------------------------------------------
checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.0.3...
*** 'pkg-config --modversion glib-2.0' returned 2.8.0, but GLIB (2.10.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: "Cannot find glib"
root@zivs-desktop:/home/zivs/Desktop/xchat-2.6.4#
------------------------------------------------------------
And yes, trying to do this on fresh Ubuntu 6.06 installation
What should (and how) I do to remove that 2.10.3 version?
Thanks in advance

kickzha 06-18-2006 07:10 AM

...im not very familiar with ubuntu...but in short my thoughts...

I cannot talk about ho to configure pkg-config - but i think the Problem is as follows:

You got different versions of Libraries in your /usr/lib Directory, and i think (have a look at the man) ldconfig links the newest lib-Versions it founds to the approprieta library.

But your pkg-config (/usr/lib/pkd-config/glib-2.0.pc) says different, ldconfig found.

So the answer to your Question? - i dont know, if you compiled the 2.8 from gtk.org-sources it's problematic. If you installed from a tarball, it's problematic - i think.

But older version doesn't have to be removed i think, only if it's akin you, or just to get free space.

Why did you install 2.8 later on to 2.10 ??

Maybe the 2.10 version you cannot deinstall because it's the recommended package to your distribution-version ??

--

If so, try to reconfigure libglib2.0-dev, may be
Code:

dpkg-reconfigure libglib2.0-dev
and check what
Code:

pkg-config --modversion glib-2.0
will say...i hope that gives 2.10.3...then the configure-Script of Xchat should run, with glib-2.0 v. 2.10.3 .


regards
kickzah

zivs 06-18-2006 07:42 AM

I can't really say why i installed 2.8.. maybe just because wanted the latest version :)
So i tried dpkg-reconfigure, but got this message:
--------------------------------------------------
root@zivs-desktop:/home/zivs# dpkg-reconfigure libglib2.0-dev
Package `libglib2.0-dev' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: libglib2.0-dev is not installed
root@zivs-desktop:/home/zivs#
--------------------------------------------------
and pkg-config --modversion says that it is 2.8.0 version

I was thinking about removing that 2.10.3 from synaptic, but it wants to remove alot of applications with it...

kickzha 06-18-2006 12:52 PM

Quote:

Originally Posted by zivs
I can't really say why i installed 2.8.. maybe just because wanted the latest version :)
So i tried dpkg-reconfigure, but got this message:
--------------------------------------------------
root@zivs-desktop:/home/zivs# dpkg-reconfigure libglib2.0-dev
Package `libglib2.0-dev' is not installed and no info is available.

...seems its called other way...or really not installed?
Quote:

Originally Posted by zivs
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: libglib2.0-dev is not installed

...try
Code:

dpkg -l libglib* | grep ii
Quote:

Originally Posted by zivs
root@zivs-desktop:/home/zivs#
--------------------------------------------------
and pkg-config --modversion says that it is 2.8.0 version

I was thinking about removing that 2.10.3 from synaptic, but it wants to remove alot of applications with it...

...that i was thinking about...

I conclude u didn't have installed libglib2.0-dev, and tried to go the way with gtk.org/gnome.org.

Maybe
Code:

apt-get install libglib2.0-dev
would have done the act, and will do it right now too. Test it!

zivs 06-18-2006 01:09 PM

Thanks for helping - libglib2.0-dev helped me out, but had an errors with perl so we (had a little help from friend over IRC) disabled it for the installation. all works fine :)


All times are GMT -5. The time now is 01:57 AM.