LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-18-2006, 10:58 PM   #1
richie314159
LQ Newbie
 
Registered: Nov 2005
Distribution: kubuntu feisty
Posts: 10

Rep: Reputation: 0
glib probs


hi,
i'm using ubuntu 5.10 and trying to install packages from source. when i try ./configure i get this error:

checking for GLIB - version >= 2.0.0... *** GLIB header files (version 2.11.1) do not match
*** library (version 2.8.3)
no
configure: error: unable to find the GLib library.

i have build-essentials installed and i've installed every libglib file i can find. does anyone have any ideas?

thanks,
rich
 
Old 05-18-2006, 11:47 PM   #2
goens
Member
 
Registered: Mar 2006
Location: San Salvador, El Salvador
Distribution: Gentoo
Posts: 32

Rep: Reputation: 15
maybe you could be more specific. What exactly are you trying to build from source?
maybe it has been linked to the bad libraries. Try checking on the projects documentation something about your problem. I don't know exactly, but look at the configure script( or your console output) if it requires a special filename vor the libraries of that version. try with:
ln -s glib.your.version glib.required.version
this in the folder where the script will look (probably /usr/lib or /usr/local/lib , not much Ubuntu experience here, sorry) but you can find out easily with a "whereis glib" command.
well Worst Case, you can download the older version of glib here and compile them yourself (but I guess you have to restart in single user mode for compiling, try with the "safe mode" boot. because these libraries are used by gnome if I am not mistaken). unfortunately there appears to be no 2.0 version listed in their servers...
OR
you will have to hack the source code and link to the apropiate header files!

good luck!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 03:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
[GLIB] Problems Installing GLIB ThA_eLMo_GoD Linux - Newbie 2 09-04-2004 06:27 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Problems relating to glib 1.2.10 and glib 1.2.9 p3ngu!n Mandriva 10 05-23-2004 10:03 PM


All times are GMT -5. The time now is 09:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration