LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-12-2004, 09:20 PM   #1
CPUguy387
Member
 
Registered: Jul 2003
Location: San Luis Obispo, CA
Distribution: Gentoo 2007.0
Posts: 88

Rep: Reputation: 15
GLIB not found when trying to install packages


I've looked online here and found a bunch of suggestions, but none have worked.

WHen tryin to intall ATK or GTK or gAIM, all require GLIB. I installed GLIB 2.2.3, but all the other programs can't find it:

checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding GLIB or finding the wrong
*** version of GLIB. If it is not finding GLIB, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/.

GLIB installed its files to /usr/local/lib.

Maybe it was installed before, but I didn't say it was when I ran these installers initially. How do I check and uninstall them andwhat is the best way to fix this?
 
Old 03-29-2004, 11:32 PM   #2
blendmaster
Member
 
Registered: Mar 2004
Location: Colorado
Distribution: Gentoo Linux 2004.1
Posts: 61

Rep: Reputation: 15
either install rpms of what you want or if you like source, find out where Red Hat installs GLIB. It might be in /usr . Then recompile glib using ./configure --prefix=<whereever its installed> instead of just ./configure. then just run make and make install normally. then try to do everything else.

If you haven't allready, put

PATH="$PATH:." in your .bashrc script so you can type "configure" instead of "./configure".
 
Old 04-03-2004, 11:21 AM   #3
C-monkey
LQ Newbie
 
Registered: Jun 2003
Location: Santa Clara Valley
Posts: 17

Rep: Reputation: 0
I posted something similar a few weeks ago under a post titled "Comiling from source - GLib error!" Likewise, I typically have experienced this problem when installing gAIM from source.

I found a couple of other relevant posts and copy-and-pasted some of the content to a text document for offline reference. I will try some of the things suggested by the various posters. One person describes this as " . . . this is a messy can of worms", but it does not seem to be an insurmountable problem.

Hopefully, I can report back with positive results

C-monkey
 
Old 05-08-2004, 06:11 AM   #4
ender1178
LQ Newbie
 
Registered: May 2004
Location: ohio
Distribution: SuSE 9.0
Posts: 3

Rep: Reputation: 0
I've been bashing my head against the same problem, here's what I've found:

1.) You must install the development RPM for GLIB. They're separate. (Should be on CD)
2.) You will also need to have the startup-notification-1.0 library installed. (Should be on CD)
3.) You will also need the libxml-2.0 library installed. (Should be on CD)
4.) You will also need the mozilla-nss library installed, you can get this at mozilla.org, do a search for "mozilla nss"

As I type I'm waiting for various updates to complete and then I get to try again! I'll report if successful.
 
Old 05-08-2004, 08:13 AM   #5
ender1178
LQ Newbie
 
Registered: May 2004
Location: ohio
Distribution: SuSE 9.0
Posts: 3

Rep: Reputation: 0
I didn't notice this was an old thread upon initial inspection; I'll post my successful result so that future googlers can spend less time than I did researching the problem.

In my post earlier, I mentioned the development GLIB library, startup-notification, libxml, and mozilla-nss (current version 3.9) which is dependent on another mozilla library, nspr, current version 4.41.

If you have all these libraries correctly installed, Gaim should compile and install correctly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
glib not found...???? HELP! PLEASE! TheCowboy Linux - Software 1 03-01-2005 02:09 AM
pygtk install found 2 versions of glib and complains Kanaflloric Linux - Software 1 09-28-2004 05:46 AM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Packages not found when trying to install Mplayer spacedout Linux - Newbie 1 08-29-2003 10:24 AM


All times are GMT -5. The time now is 04:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration