LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-18-2003, 08:36 AM   #1
nodger
Member
 
Registered: Oct 2003
Location: Ireland
Distribution: Slackware 9.1, Ubuntu
Posts: 192

Rep: Reputation: 30
Angry GLIB not being seen


First of all , I'm a newbie, using Red hat 9
Now
I installed glib 2.2.3 by extracting the tarball, opening a terminal and typing

./configure
make
make install

that seemed to go ok. But when I try to install pango 1.2.5

I get the following error message during the configure process:

checking for GLIB - version >= 2.1.3... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** Glib 2.1.3 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.

...after which it exits.

WHAT I KNOW:
-The configure script cannot find a glib installation with a version
greatet than or equal to 2.1.3
WHAT I DONT KNOW:
-Where the configure script looks in order to come to this conclusion
-What the configure script looks for in order to come to this conclusion
-Most other things about Linux

can somebody PLEASE give me some suggestions as to what is the most likely thing
that has gone wrong here. as I said I'm a newbie, but I need this in time for tomorrow.

Many Thanks
 
Old 10-18-2003, 08:45 AM   #2
pablob
Member
 
Registered: Apr 2003
Location: Madrid
Distribution: RHEL, Kubuntu, Solaris, TRU64
Posts: 382

Rep: Reputation: 31
Didn't glib and pango got installed with RH9 installer?
Why you got a source package instead of a compiled one if you are new to this, man?

You could cut some of your fingers to make it more difficult ;-)

Seriously, can't you install glic & pango binary rpm packages ?
 
Old 10-23-2003, 02:04 PM   #3
Jefklak
LQ Newbie
 
Registered: Oct 2003
Distribution: Currently Fedora B3, Will try Gentoo 1.4
Posts: 26

Rep: Reputation: 15
Check my reply in
http://www.linuxquestions.org/questi...ighlight=pango
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 03:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
[GLIB] Problems Installing GLIB ThA_eLMo_GoD Linux - Newbie 2 09-04-2004 06:27 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Problems relating to glib 1.2.10 and glib 1.2.9 p3ngu!n Mandriva 10 05-23-2004 10:03 PM


All times are GMT -5. The time now is 08:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration