I've got a similar problem so I won't start a new thread. I installed glib-2.2.3 without incident. I then ran ldconfig and had same problems as Alderian trying to ./configure on another program. So then I ran
like hfwazy said but I get this error when I try to ./configure on another package:
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.1.3...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
*** Glib 2.1.3 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.
I'm not sure what to do. I'm trying to install the latest verions of gtk+, but I'm working on the dependencies now. Thanks for any help.