LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-08-2003, 10:06 PM   #1
ajm36
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Rep: Reputation: 0
Glib install problem


I installed glib-2.2.3. Then I tried installing ATK so that I could install GTK. When I used the configure command for ATK I got the following error:

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.0.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

I modified both the LD_LIBRARY_PATH and the PKG_CONFIG_PATH to include the directory that contained the .pc files (/usr/local/lib/pkgconfig). I used the export command to do this and when I echoed the variables, the only directory listed was /usr/local/lib/pkgconfig. I also edited the ld.so.conf. file to include this directory and ran ldconfig. I still get the same error while trying to configure ATK. I can not find glib-2.0.6 so that I can remove it. I am not even sure if the .pc files are what is being looked for or if there are configuration files somewhere else. I have seen similar posts for what appears to be the same problem, but I have found no good answers. Please, please help. Thanks.
a.j.
 
Old 10-09-2003, 01:15 AM   #2
MultiMike
LQ Newbie
 
Registered: Jun 2003
Distribution: Slackware
Posts: 9

Rep: Reputation: 0
Yeah I"m stuck at the same spot... wish this compiled & installed as easily as all of kde's stuff did
 
Old 10-10-2003, 01:14 AM   #3
ajm36
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Original Poster
Rep: Reputation: 0
I found something interesting. If you delete libglib-2.0.so.0.0.6 from /usr/lib, ATK gives a different configuration error. There are libglib files for glib-2.2.3 in /usr/local/lib. Maybe deleting all of the earlier versions (of libglib, libgmodule, libgobject, and libgthread) from /usr/lib and COPYING the newer versions into /usr/lib will work.
a.j.
 
Old 10-10-2003, 01:44 AM   #4
ajm36
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Original Poster
Rep: Reputation: 0
I did what I said in my last post and this seems to have solved the problem. I was able to install ATK without a problem. Now to see if GTK works.....
a.j.
 
Old 10-10-2003, 10:54 AM   #5
MultiMike
LQ Newbie
 
Registered: Jun 2003
Distribution: Slackware
Posts: 9

Rep: Reputation: 0
I just stumbled upon a solution that worked for me last night. When installing glib, atk, pango, & gtk, give them the /usr prefix when you configure ( ./configure --prefix=/usr). Unlike slackware and gentoo, red hat eviently requires the /usr prefix, and not the usual /usr/local. Hope this helps for anybody out there who experiences the same prob.
 
Old 10-10-2003, 03:47 PM   #6
ajm36
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks. Works better than what I did.
 
Old 10-10-2003, 08:56 PM   #7
kaega2
Member
 
Registered: Sep 2003
Location: Ontario, Canada
Distribution: Gentoo 2004.3
Posts: 195

Rep: Reputation: 30
I've heard that before and was unable to get it to work. is this when you're configuring the glib install or the gtk? or is it both?

also, i'm using mandrake. could you tell me what's specific in that directory so that if it's different in mandrake i can make changes.

thanks
 
Old 10-11-2003, 06:51 PM   #8
ajm36
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Original Poster
Rep: Reputation: 0
This must definitely be done with glib. I am using a RedHat 8 installation, and the the gtk would only work after I installed it both ways (the default and --prefix=/usr). Incidentally, I also had to install atk and pango this way. However, my system has since crashed after updating a few other libraries. When I am completely up and running, I'll post again--but I'm leaving tomorrow and won't be back for a couple of weeks (like anyone cares). Later.
a.j.
 
Old 10-13-2003, 11:53 AM   #9
kaega2
Member
 
Registered: Sep 2003
Location: Ontario, Canada
Distribution: Gentoo 2004.3
Posts: 195

Rep: Reputation: 30
I'm trying to install arts (component of xmms) and it gives the same error (with glib). It's all I really care about, because I'm trying to get my xmms up and running again.

I can't play mp3's because xmms gives me an error. I tried reinstalling glib with "./configure --prefix=/usr" and installed arts using the same command line and it gives me the glib error. I've seen this solution on the internet before and I think it's just a matter of picking a different director for mandrake. I don't know which directly I'm looking for though. I'm new to linux all together. Music is the most important thing in an OS for me and I've temerarily switched back to windows until I've figured out a way to get this fixed

Any suggestions would be appreciated, anything that you might have tried to get this to work. Anyone who's had this problem with mandrake would be preferred

Thanks
 
Old 10-23-2003, 02:05 PM   #10
Jefklak
LQ Newbie
 
Registered: Oct 2003
Distribution: Currently Fedora B3, Will try Gentoo 1.4
Posts: 26

Rep: Reputation: 15
About those libraries and ./configure == check my reply at
http://www.linuxquestions.org/questi...ighlight=pango

xmms & MP3s don't work if you use RedHat because of licence problems. There's a patch somewhere on the internet wich enables you playing them anyway, search for it on this forum (I found it too here) or on google.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
GLib install problem nolimitz Linux - Software 8 08-03-2005 07:24 AM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Glib install problem juanb Linux - Software 1 06-30-2004 09:23 AM
glib install problem ajm36 Linux - Software 5 10-17-2003 04:40 AM


All times are GMT -5. The time now is 02:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration