LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-11-2004, 05:02 AM   #1
thef0x
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
GLIB help


its 3 am and i'm still no where, haha. i need the newest version of glib, atk, and pango to run GTK and xmms. sadly i can't get glib to install. i've deleted it from /usr/lib/ and re-configured and make/make installed it. (./configure --prefix=/usr/lin/glib-2.4/ make make install). it says i need to change something with PKG_CONFIG+PATH but i checked my pgkconfig folder in usr/lib/ and i have a new glib-2.0.pc file that points to my glib-2.4.0 folder.. yet it still cant recognize it, can someone help me.



checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0... Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing `atk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'atk' found

configure: error: Library requirements (glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.


if someone can help me out, when i try to get ATK to config it says the GLIB version is bad.
 
Old 04-11-2004, 07:55 AM   #2
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
Is ATK looking for the GLIB version that you deleted? The only way I got to update GLIB was to upgrade distros.

Baldrick
 
Old 04-15-2004, 11:34 AM   #3
rogk
Member
 
Registered: Feb 2004
Location: Finland
Distribution: Mandrake 10.0
Posts: 70

Rep: Reputation: 15
Hello "thef0x". Have you resolved your problem? I ask it, because I have the same problem with gtk+. I would like to install Gimp 2.0. And to install Gimp I need gtk+ and to install gtk+ I need to install Pango,Glib and Atk-libraries. So if you know what to do, please tell me.
 
Old 04-15-2004, 12:31 PM   #4
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Why are you putting glib in such a non-standard folder? If you configure it so it goes into /usr/lib (--prefix=/usr) then everything will find it just fine. All the problems I had with GTK2 were from trying to put it in a nonstandard place, and my PKG_CONFIG_PATH variable is properly defined.
 
Old 08-08-2004, 03:23 AM   #5
JuhaA
LQ Newbie
 
Registered: Aug 2004
Location: Finland
Distribution: Suse 9.3
Posts: 3

Rep: Reputation: 0
Same problems here, but I solved!

First execute these lines (I put those on my AND root's .bash_profile -script. Easier life in future):
PKG_CONFIG_PATH="/usr/local/lib/pkgconfig"
LD_LIBRARY_PATH="/usr/local/lib"
export PKG_CONFIG_PATH LD_LIBRARY_PATH

Before install nothing, do as "root":
ldconfig

Use on every package default prefix (atk, glib, pango, gtk+):
./configure --prefix=/usr

that's it
JuhaA
 
Old 08-08-2004, 06:29 AM   #6
JuhaA
LQ Newbie
 
Registered: Aug 2004
Location: Finland
Distribution: Suse 9.3
Posts: 3

Rep: Reputation: 0
Of cource I forget something!

GTK+ need TIFF-pagace! So then we install that before install gtk+...

1) Download it from ftp://ftp.remotesensing.org/pub/libt...-v3.6.1.tar.gz (latest 8.8.2004)

2) export LDFLAGS="-L/usr/lib -ltiff"

3) Then you can compile and install gtk+ without any errors!

JuhaA
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 02:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
[GLIB] Problems Installing GLIB ThA_eLMo_GoD Linux - Newbie 2 09-04-2004 05:27 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
Problems relating to glib 1.2.10 and glib 1.2.9 p3ngu!n Mandriva 10 05-23-2004 09:03 PM


All times are GMT -5. The time now is 04:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration