Linux - NewbieThis Linux forum is for members that are new to Linux.
Just starting out and have a question?
If it is not in the man pages or the how-to's this is the place!
Welcome to LinuxQuestions.org, a friendly and active Linux Community.
You are currently viewing LQ as a guest. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. Registration is quick, simple and absolutely free. Join our community today!
Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.
If you have any problems with the registration process or your account login, please contact us. If you need to reset your password, click here.
Having a problem logging in? Please visit this page to clear all LQ-related cookies.
Introduction to Linux - A Hands on Guide
This guide was created as an overview of the Linux Operating System, geared toward new users as an exploration tour and getting started guide, with exercises at the end of each chapter.
For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration. This book contains many real life examples derived from the author's experience as a Linux system and network administrator, trainer and consultant. They hope these examples will help you to get a better understanding of the Linux system and that you feel encouraged to try out things on your own.
Click Here to receive this Complete Guide absolutely free.
First off, I apoilige if this has been covered before as I searched and didn't find anything close to my issue.
I am runnig FC4 on a P4 and have just got done installing many libs and new progs. One being xmms. I downloaded a plugin for xmms. It is an alarm plugin and when I try to do the ./configure, I receieve a message;
checking for GLIB - version >= 1.2.6... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
*** GLIB >= 1.2.6 not installed - please install GLIB first ***
Now I am sure that I have installed glib. I have searched my whole filesystem for glib and the following are the results.
The error is because glib-1.2.X and glib 2.0.X are not compatible libraries. That means, even though 2.0 is >= 1.2.6 from a straight version comparison, it doesn't matter because the glib library was re-tooled for the 2.0 series. The way applications interact with the 2.0.X library is fundamentally different from the way applications interact with 1.2.X.
Your system seems to have the glib-2.0.X development package/header files installed, but the program your compiling needs the glib-1.2.X development package. You'll need to install the glib-1.2.X development package for the compilation to work.
I don't know how each distribution refers to those development packages. Maybe someone will pipe up and give that information, or you could do a search online based on your distro to find out the naming scheme.