LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-21-2005, 02:07 PM   #1
sfunk1x
LQ Newbie
 
Registered: Nov 2002
Location: Portland, OR
Distribution: Fedora Core 3
Posts: 18

Rep: Reputation: 0
Glib 2.6.1 and GTK+ 2.6.1 issues - please help!


I apologize if this is in a previous thread - I spent hte last 2 hours searching and none of the posts I found have gotten me any farther (as I've tried most of them sans creating symlinks which I don't think I shoul dhave to do, because I've never done it in past distros of Redhat..)

Basic configuration:

IBM Laptop P4 2.0ghz
Fedora Core 3 install with latest updates

I have extracted Glib 2.6.1 in /usr/local/src/glib-2.6.1 and ran ./configure/make/make install. When I extract GTK+-2.6.1 in /usr/local/src/gtk+-2.6.1, and then run ./configure in a terminal as root, it complains of the following:

>>
checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.7.0... Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found

configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.7.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
>>

What is the deal? I'm assuming that when I run "make install" that it is copying the libraries into the proper folders - either like /usr /lib or /use/local/lib, or both. I don't ever remember having to do this with redhat 7 or 8 (which is the last time I used linux, kernel 2.4.18 or .20 or something like that). What has changed? Has my crack supply dwindled in quality or is there something basic I am missing? I don't remember having to create symlinks to accomplish any of this stuff.... nor do I know if that wille ven work.

any help is greatly appreciated! help me keep linux on my laptop! :-)
 
Old 01-21-2005, 02:20 PM   #2
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Ok, do these commands for me. ldconfig must be done as root; everything else as the useryou're trying to compile with:
Code:
ldconfig -v | grep glib
find / -name "glib-2.0.pc" -o -name "glib2-config" 2>/dev/null
echo $PKG_CONFIG_PATH
echo $PATH
 
Old 01-21-2005, 02:46 PM   #3
sfunk1x
LQ Newbie
 
Registered: Nov 2002
Location: Portland, OR
Distribution: Fedora Core 3
Posts: 18

Original Poster
Rep: Reputation: 0
[root@bluebird /]# ldconfig -v | grep glib
libglib-2.0.so.0 -> libglib-2.0.so.0.600.1
/usr/local/src/glib-2.6.1:
libglib-1.2.so.0 -> libglib-1.2.so.0.0.10
libglib-2.0.so.0 -> libglib-2.0.so.0.400.8
libdbus-glib-1.so.0 -> libdbus-glib-1.so.0.0.0
libgw-glib.so.0 -> libgw-glib.so.0.0.0
libgwrap-glib.so.1 -> libgwrap-glib.so.1.0.0

>>

[root@bluebird /]# find / -name "glib-2.0.pc" -o -name "glib2-config" 2>/dev/null
/usr/local/src/glib-2.6.1/glib-2.0.pc
/usr/local/lib/pkgconfig/glib-2.0.pc

>>

[root@bluebird /]# echo $pkg_config_path

[root@bluebird /]# echo $PKG_CONFIG_PATH

[root@bluebird /]# echo $PATH
/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin

>>

Thanks in advance!
 
Old 01-21-2005, 03:01 PM   #4
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Alright, give this a try for me now:
Code:
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
After doing that, try to run the configure script for GTK-2 again. If it works, we'll need to make the change permanent.

=========================================================

Explanation of previous commands (if anyone is curious):

Ok, the ldconfig command says that glib2 is installed, and the compiler can find it to link against.

The find command made sure the glib-2.0.pc file exists somewhere other than the source tree (i.e. it's been installed) However, I was hoping for a file named "glib2-config" as well; might just have the name wrong on that one. Essentially, both have the same information: where the headers were installed, and what command line options the compiler needs to include to use the code with other software.

Echo'ing $PKG_CONFIG_PATH is just checking to make sure the pkg-config command is checking all the necessary places to find *.pc files.

Echo'ing $PATH was similarly checking to make sure the glib2-config was in the user's path. Again, perhaps it named something else, or perhaps glib2 doesn't include it.

Last edited by Dark_Helmet; 01-21-2005 at 03:03 PM.
 
Old 01-21-2005, 03:13 PM   #5
wpn146
Member
 
Registered: Jan 2005
Distribution: Solaris, Linux Fedora Core 6
Posts: 170

Rep: Reputation: 30
You need:

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig

Also, your ldconfig command is outputing the line:
/usr/local/src/glib-2.6.1:

I can't see the context around that line because the grep did not catch it, but /usr/local/src is the directory containing the source build tree, not the location where the where glib is installed. Did you redirect this with a "--prefix=" when configuring glib? This would also explain why the glib-2.0.pc file was not where it was expected.
 
Old 01-21-2005, 03:14 PM   #6
sfunk1x
LQ Newbie
 
Registered: Nov 2002
Location: Portland, OR
Distribution: Fedora Core 3
Posts: 18

Original Poster
Rep: Reputation: 0
echo $PKG_CONFIG_PATH now states that the path is /usr/local/lib/pkgconfig, but when I run ./configure in gtk+-2.6.1, it's still coming up with the same error.

DUR
>>
checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.7.0... Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing `atk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'atk' found

configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.7.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

>>

OK, you gave me some great help, but I was blind as a bat. I'm going to download the latest ATK and install that, then post back my results.
 
Old 01-21-2005, 03:23 PM   #7
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
The -v option to ldconfig will print the directory the library was found in as a "header" so to speak. I imagine ldconfig output the line "/usr/local/src/glib-2.6.1:" because that directory was added to ld.so.conf. I have a feeling sfunk1x tried adding that to solve his problem initially.

Everything looks ok to me. It's just that glib2 was installed to a tree other than where pkg-config was installed. Otherwise, the default path pkg-config searches would have picked up the glib-2.0.pc file.

So yeah, you'll need to download and install ATK and all the other goodies the configure script lists that you don't have. Also, remember to run ldconfig after you install a library (at least, before you compile something that wants to link against it).
 
Old 01-21-2005, 03:45 PM   #8
sfunk1x
LQ Newbie
 
Registered: Nov 2002
Location: Portland, OR
Distribution: Fedora Core 3
Posts: 18

Original Poster
Rep: Reputation: 0
OK...

>>
checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.7.0... Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing `atk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'atk' found

configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.7.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
[root@bluebird gtk+-2.6.1]# rpm -qa atk
atk-1.8.0-2_1.rhfc3.at



>>

The wierd thing is.. this is a standard, alomost full install of Fedora Core 3. When I perform an rpm-qa atk these are the results:

[root@bluebird gtk+-2.6.1]# rpm -qa atk
atk-1.8.0-2_1.rhfc3.at

>>

Yet, I am still getting the error message above. When I built Glib 2.6.1, I did not add the prefix line, as I didn't understand that I needed it. I tried the man page but I still wasn't clear after reading it. Should I rebuild glib and add the prefix flag so it adds the .pc file?

Also, why, after using an RPM to install the latest ATK (which FC3 already had I believe), would it not find the pc file for atk? I'd think that woul dbe a nobrainer considering there was practically no use rinteraction during the install. What am I missing here?

thanks for the noob help!
 
Old 01-21-2005, 04:01 PM   #9
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Here's the deal. In the "wisdom" of package maintainers, support software is split into two pieces: the "normal" package and a "devel" package.

The assumption is, if you're using a package manager, you're not actually going to compile anything by hand; you'll just use the package manager to install whatever you need. In doing so, you're trusting someone else to do the compiling for you. Well, there are files used in compilation that are not needed after the compilation is finished. Those files get stripped out of the "normal" packages in an effort to save space. Again, you're using a package manager, and won't need to compile anything yourself.

Those orphaned files get shoved into the "devel" package. So, if you plan to do any compiling of software that uses a library (such at ATK), then you need to install the development package. They should be on your install CDs or downloadable from the same place you got the normal package from. Typically, they just have "-devel" sandwiched in the file name. Once installed, then you can compile against it.

I'm not a big fan of this strategy, but that's the way it is. So go hunt down the devel package and install it, and you should be ok.

Last edited by Dark_Helmet; 01-21-2005 at 04:02 PM.
 
Old 01-21-2005, 04:21 PM   #10
sfunk1x
LQ Newbie
 
Registered: Nov 2002
Location: Portland, OR
Distribution: Fedora Core 3
Posts: 18

Original Poster
Rep: Reputation: 0
OK. Awesome. I'm going to take care of the ATk dev install in a moment.

So, how do I go about making that path permenant, so future packages won't complain about glib?
 
Old 01-21-2005, 04:34 PM   #11
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Open up /etc/profile (you'll need to be root to edit it). Scroll down to the bottom of the file, and add the export command exactly like mentioned before. Save the file and exit.

The next time you log in, you can double-check it's there by doing the echo $PKG_CONFIG_PATH thing.

Keep in mind, that if you open a new terminal in your current session, it's not the same thing as logging in. That's just a side effect of how X works. You'll have to completely log out, and if you're not sure what I mean by that, then a reboot will take care of it.
 
Old 01-21-2005, 06:33 PM   #12
sfunk1x
LQ Newbie
 
Registered: Nov 2002
Location: Portland, OR
Distribution: Fedora Core 3
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks to everyone who replied! Everything has been installed, and now I can isntall the packages that I wanted to install.

Thanks for the assistance. Now to move onto other projects.. :-)
 
Old 01-21-2005, 06:36 PM   #13
wpn146
Member
 
Registered: Jan 2005
Distribution: Solaris, Linux Fedora Core 6
Posts: 170

Rep: Reputation: 30
Quote:
Originally posted by sfunk1x
echo $PKG_CONFIG_PATH now states that the path is /usr/local/lib/pkgconfig, but when I run ./configure in gtk+-2.6.1, it's still coming up with the same error.

DUR
>>
checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.7.0... Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing `atk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'atk' found

configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.7.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

>>

OK, you gave me some great help, but I was blind as a bat. I'm going to download the latest ATK and install that, then post back my results.
This is a different message. You fixed glib, not it needs the same fix for atk. pango comes next. I think pango is the last of the madness, but I am not sure. I was building gimp-2.2.2 and needed more yet. If you are putting everything in /usr/local, all of the ".pc" files should end up there and be found. If you change the "--prefix=" to somewhere else, like "--prefix=/my/new/path", add "/my/new/path/lib/pkgconfig" to PKG_CONFIG_PATH.
 
Old 02-02-2005, 06:30 AM   #14
mkld2005
LQ Newbie
 
Registered: Feb 2005
Location: Malaysia
Posts: 2

Rep: Reputation: 0
Fedora Core 3 does not have the glib version that gtk+2.6.1 needs. If you look at /usr/lib/pkgconfig
and open the glib-2.0.pc file it states that the glib version is "Version: 2.4.7". gtk+2.6.1 needs glib-2.6.0
or greater. You'll need to upgrade the glib, atk, and pango libraries first before ./configure for the gtk+-2.61
stop complaining about those.
 
Old 02-02-2005, 06:40 AM   #15
mkld2005
LQ Newbie
 
Registered: Feb 2005
Location: Malaysia
Posts: 2

Rep: Reputation: 0
Oops! I only got to see the full thread of your post after send my post. Seems you got it lick already.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Freerock uninstall stole GTK looking for up-to-date pango, atk, gtk, glib and xft tgz Oholiab Slackware 8 09-18-2005 12:57 PM
glib and gtk + charnel Linux - Software 3 04-13-2005 11:46 AM
Trouble installing XMMS, gtk/glib issues. MDBlueIce Linux - Newbie 11 02-26-2005 10:00 PM
Glib/gtk what is it ? i really need him ? SlackwareMan Linux - Newbie 6 07-31-2004 06:56 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM


All times are GMT -5. The time now is 07:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration