LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-30-2003, 12:49 PM   #1
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Rep: Reputation: 30
Unhappy glib-2.0 help!


checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.0 libxml-2.0 >= 2.4... Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found

configure: error: Library requirements (glib-2.0 >= 2.0 libxml-2.0 >= 2.4) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

How do you the configure script to look for glib in a different location, and where might I find glib in redhat 9.? thanks!
 
Old 07-30-2003, 01:31 PM   #2
youngstorm
Member
 
Registered: May 2003
Location: USA
Distribution: Fedora 21, RHEL 5,6&7, Windoze 7
Posts: 235

Rep: Reputation: 31
Type "pkg-config --list-all | grep glib-2.0" just to see if pkg-config really
is not seeing it or maybe there is another problem.
Also, make sure that /usr/lib is in the file /etc/ld.so.conf, if it is not, put it
there. Then run 'ldconfig'.
See if that helps.
 
Old 07-30-2003, 01:47 PM   #3
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
$ pkg-config --list-all | grep glib-2.0
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
Package 'gtk+-2.0', required by 'libpanel-applet-2', not found
It's definitely not seeing it.
 
Old 07-30-2003, 02:12 PM   #4
youngstorm
Member
 
Registered: May 2003
Location: USA
Distribution: Fedora 21, RHEL 5,6&7, Windoze 7
Posts: 235

Rep: Reputation: 31
Do you see 'glib-2.0.pc' in '/usr/lib/pkgconfig/' . If not do this
'locate glib-2.0.pc'. If that finds the file, try coping the file to
'/usr/lib/pkgconfig/'
 
Old 07-30-2003, 02:24 PM   #5
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
glib-2.0.pc is not in /usr/lib/pkgconfig but
$ locate glib-2.0.pc
does nothing.

oh yeah, and /usr/lib was not in /etc/ld.so.conf I added it but bash says ldconfig not found.

Last edited by KptnKrill; 07-30-2003 at 02:31 PM.
 
Old 07-30-2003, 02:34 PM   #6
youngstorm
Member
 
Registered: May 2003
Location: USA
Distribution: Fedora 21, RHEL 5,6&7, Windoze 7
Posts: 235

Rep: Reputation: 31
Are you logged in as root. If not try this things again as root.
If you are root, did you do a full installation of RH9?
 
Old 07-30-2003, 02:40 PM   #7
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
I ran ldconfig as root an that gave me a fresh line. (Not sure if that's what it's supposed to do). And locate glib-2.0.pc does the same thing. What do I do now?

Last edited by KptnKrill; 07-30-2003 at 04:33 PM.
 
Old 07-30-2003, 05:14 PM   #8
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
I found libglib-2.0.so.0 and libglib-2.0.so.0.200.1 in /usr/lib in case this helps anyone. Please, does anyone know where I can find the glib-2.0.pc file, or how I could search for it. (So far I've been looking through the directories myself and locate glib-2.0.pc doesn't seem to work.
 
Old 07-30-2003, 09:50 PM   #9
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
youngstorm? anyone?
 
Old 07-31-2003, 09:00 AM   #10
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
youngstorm,
I don't think that glib is on my machine. I did a
$ locate "*.pc"
and it wasn't there.
 
Old 07-31-2003, 11:33 AM   #11
youngstorm
Member
 
Registered: May 2003
Location: USA
Distribution: Fedora 21, RHEL 5,6&7, Windoze 7
Posts: 235

Rep: Reputation: 31
Heck, try this. copy my '/usr/lib/pkgconfig/glib-2.0.pc'. Make your file
same place as mine. Then see if it works. Copy everything below. Good luck.


prefix=/usr
exec_prefix=/usr
libdir=/usr/lib
includedir=/usr/include

glib_genmarshal=glib-genmarshal
gobject_query=gobject-query
glib_mkenums=glib-mkenums

Name: GLib
Description: C Utility Library
Version: 2.2.1
Libs: -L${libdir} -lglib-2.0
Cflags: -I${includedir}/glib-2.0 -I${libdir}/glib-2.0/include
 
Old 07-31-2003, 12:35 PM   #12
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
It worked! thanks a ton!
Just one more thing. Can I have your libgnome-2.0.pc file too?

Last edited by KptnKrill; 07-31-2003 at 12:39 PM.
 
Old 07-31-2003, 12:50 PM   #13
youngstorm
Member
 
Registered: May 2003
Location: USA
Distribution: Fedora 21, RHEL 5,6&7, Windoze 7
Posts: 235

Rep: Reputation: 31
Kool deal. Sure It is below. Let me know if it works, too.

prefix=/usr
exec_prefix=/usr
libdir=/usr/lib
includedir=/usr/include
libgnome_serverdir=/usr/libexec

Name: libgnome
Description: libgnome
Requires: glib-2.0 ORBit-2.0 libbonobo-2.0 gconf-2.0 gnome-vfs-2.0
Version: 2.2.0.1
Libs: -L${libdir} -lgnome-2
Cflags: -I${includedir}/libgnome-2.0
 
Old 07-31-2003, 01:24 PM   #14
KptnKrill
Member
 
Registered: Apr 2003
Location: US, MA
Distribution: Nandu-0.ab, Arch 0.7.2
Posts: 229

Original Poster
Rep: Reputation: 30
Cool it worked again! K, now I need someone's ORBit-2.0.pc file, thanks!
 
Old 07-31-2003, 03:20 PM   #15
youngstorm
Member
 
Registered: May 2003
Location: USA
Distribution: Fedora 21, RHEL 5,6&7, Windoze 7
Posts: 235

Rep: Reputation: 31
Here you go you go.


prefix=/usr
exec_prefix=/usr
libdir=/usr/lib
includedir=/usr/include
orbit_idl=/usr/bin/orbit-idl-2


Name: ORBit-2.0
Description: High-performance CORBA Object Request Broker.
Version: 2.6.0
Requires: linc glib-2.0 gmodule-2.0
Libs: -L${libdir} -lORBit-2 -pthread -Wl,--export-dynamic -llinc -lgthread-2.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lm
Cflags: -I${includedir}/orbit-2.0 -DORBIT2=1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 02:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
[GLIB] Problems Installing GLIB ThA_eLMo_GoD Linux - Newbie 2 09-04-2004 05:27 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
Problems relating to glib 1.2.10 and glib 1.2.9 p3ngu!n Mandriva 10 05-23-2004 09:03 PM


All times are GMT -5. The time now is 02:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration